Take Command 25.0:

 

Take Command:

 

Take Command Verbraucht wesentlich weniger CPU, wenn Sie über mehrere Registerkarten verfügen und keine Registerkartengruppen oder Splitterfenster verwenden.

 

Die Kommunikation zwischen Take Command und TCC ist viel schneller und verbraucht weniger CPU-Zeit.

 

Das Beschneiden, Überlappen und Skalieren von Rahmenschatten wurde in Umgebungen mit mehreren Monitoren und mehreren DPI behoben.

 

Viele Inkonsistenzen im Office 2013/2016- und Visual Studio 2015-Design behoben.

 

Die DPI-Unterstützung für die Steuerelemente „Bearbeiten“, „Kontrollkästchen“ und „Combobox“ wurde verbessert.

 

Sie können die Transparenz des TCMD-Fensters mit Strg-Umschalt-Mausrad ändern.

 

Sie können jetzt jedes System abmelden, vorausgesetzt, Sie verfügen über den Original-Aktivierungsschlüssel und den Namen des Computers, den Sie abmelden möchten. Der Registrierungsdialog verfügt über ein Feld „Systemname“ für den Computernamen (standardmäßig wird das aktuelle System verwendet). Geben Sie den Namen ein und klicken Sie auf die Schaltfläche „Registrierung aufheben“, um das angegebene System zu entfernen. TCMD öffnet in Ihrem Browser eine Webseite mit dem Ergebnis der Abmeldung.

 

Sie können jetzt auf jedem System einen manuellen Schlüssel (einen, der keine Internetaktivierung erfordert) generieren, vorausgesetzt, Sie verfügen über den ursprünglichen Aktivierungsschlüssel und den Namen des zu registrierenden Computers und das System, auf dem Sie den Schlüssel anfordern, verfügt über Internetzugang. Der Registrierungsdialog verfügt über ein Feld „Systemname“ für den Computernamen (standardmäßig wird das aktuelle System verwendet). Geben Sie den Namen ein und klicken Sie auf die Schaltfläche „Manuellen Schlüssel anfordern“. TCMD öffnet eine Webseite in Ihrem Browser, die den manuellen Schlüssel zurückgibt. Kopieren Sie diesen Schlüsselwert und geben Sie ihn im Feld „Aktivierungsschlüssel“ im Registrierungsdialog auf dem Computer ein, den Sie registrieren möchten.

 

Sie können nun Ihre Lizenzinformationen auf dem Registrierungsserver anzeigen. Rufen Sie den Registrierungsdialog auf, geben Sie Ihren Aktivierungsschlüssel ein und klicken Sie auf die Schaltfläche „Lizenzinformationen anzeigen“. TCMD öffnet in Ihrem Browser eine Webseite, auf der die maximale Anzahl der Systeme, die Sie registrieren können, die Namen der registrierten Systeme und das Datum ihrer Registrierung angezeigt werden.

 

Dem Menü „Startseite/Datei“ wurde ein neuer Eintrag hinzugefügt:

 

Puffer löschenLöschen Sie den Inhalt des Bildschirmpuffers des aktuellen Registerkartenfensters.

 

Dem Menü „Bearbeiten“ wurde ein neuer Eintrag hinzugefügt:

 

Kopieren+AnhängenHängen Sie die aktuelle Auswahl an den vorhandenen Inhalt der Zwischenablage an.

 

Dem Tabs-Menü (und dem Kontextmenü beim Rechtsklick auf eine Tab-Beschriftung) wurde ein neuer Eintrag hinzugefügt:

 

Trennen + AusblendenLöst die Lasche ab, lässt sie jedoch verborgen. Mit der Option „Tabs anhängen“ kann es wieder angehängt werden.

 

Das Rechtsklick-Kontextmenü des Registerkartenfensters verfügt über eine neue Option: „Kopieren+Anhängen“ hängt die aktuelle Auswahl an den vorhandenen Inhalt der Zwischenablage an.

 

Wenn Sie die Linux-Auswahloption aktiviert haben und Sie einen Block markieren und die linke Maustaste bei gedrückter Umschalttaste loslassen, hängt TCMD die Auswahl an die Zwischenablage an.

 

Wenn Sie die Linux-Auswahloption aktiviert haben und Sie bei gedrückter Umschalttaste doppelklicken, hängt TCMD die Auswahl an die Zwischenablage an.

 

Wenn Sie die Linux-Auswahloption aktiviert haben und Sie dreimal mit gedrückter Umschalttaste klicken, hängt TCMD die Zeile an die Zwischenablage an.

 

Eine Strg-W-Taste schließt die aktuelle Registerkarte (wie Strg-F4), vorausgesetzt, Sie haben entweder die linke oder rechte Steuertaste für aktiviert Take Command. (Siehe OPTIONEN / Take Command / Tabs / Windows.)

 

Mit der Tastenkombination Strg-Umschalt-C wird die aktuelle Auswahl an den vorhandenen Inhalt der Zwischenablage angehängt.

 

Das Scintilla-Bearbeitungssteuerelement wurde auf Version 4.2.0 aktualisiert.

 

Der reguläre Ausdrucksanalysator (Extras/RegEx) verfügt jetzt über einen Mikrosekunden-Timer (rechts neben dem Bearbeitungssteuerelement „Test“), der die Zeit misst, die zum Auswerten des Ausdrucks benötigt wurde.

 

Der Regular Expression Analyzer verfügt über einen „Spickzettel“ mit RE-Syntax und allgemeinen Ausdrücken.

 

Sie können die verschieben Take Command Fenster nach oben aus der Anzeige („Quake-Konsole“) und wieder nach unten mit Strg-Alt-Eingabetaste.

 

Sie können die Zeile, in der sich der Cursor befindet, mit der neuen CursorLineColor-Direktive in TCMD.INI hervorheben. Stellen Sie es mit OPTIONS / ein. Take Command / Tabs / Windows / Cursorzeile.

 

Wenn Sie die Schriftgröße des Tab-Fensters mit Strg-Mausrad oder den Menüoptionen „Vergrößern/Verkleinern“ ändern, wird die neue Schriftgröße nur auf das aktuelle Tab-Fenster angewendet; Daher kann jedes Tab-Fenster seine eigene Größe haben. (Irgendwann unterstützt jedes Tab-Fenster optional auch seine eigene Schriftart, jedoch nicht in dieser Version.)

 

If Take Command abstürzt oder von einer anderen App beendet wird, werden die ausgeblendeten Konsolenfenster nach 5 Sekunden wieder eingeblendet, sodass sie geschlossen oder wieder verbunden werden können.

 

 

TCC:

 

TCC wurde umfassend umgeschrieben, um Multithreading (fast) überall zu unterstützen. Beispielsweise kann ein Plugin andere interne Befehle, Aliase und Batchdateien ausführen, ohne dass es zu Konflikten mit dem Hauptthread kommt. Beachten Sie, dass dies nicht bedeutet, dass die Windows-Konsolen-APIs Multithreading unterstützen. Wenn Sie mehrere Threads gleichzeitig ausgeben, erhalten Sie eine durcheinandergebrachte Ausgabe. Aufgrund von Einschränkungen in Windows wird die Verarbeitung von Konsolenereignissen (^C, ^Break, Herunterfahren, Abmelden usw.) nur vom Hauptthread gesehen und verarbeitet.

 

TCC ist mit dem neuen Windows 10 Terminal kompatibel (derzeit in der Vorschau).

 

Einige der weniger häufig verwendeten DLLs wurden so geändert, dass sie bei Bedarf geladen werden, was die Startzeit und den RAM-Bedarf leicht reduziert.

 

Alle Internet-/Netzwerk-/ZIP-Bibliotheken von IPWorks wurden aktualisiert.

 

Die Onigmo-Bibliothek für reguläre Ausdrücke wurde aktualisiert.

 

Unterstützung für Python 3.8 hinzugefügt.

 

Sie können jetzt jedes System abmelden, vorausgesetzt, Sie verfügen über den Original-Aktivierungsschlüssel und den Namen des Computers, den Sie abmelden möchten. Der Registrierungsdialog verfügt über ein Feld „Systemname“ für den Computernamen (standardmäßig wird das aktuelle System verwendet). Geben Sie den Namen ein und klicken Sie auf die Schaltfläche „Registrierung aufheben“, um das angegebene System zu entfernen. TCC öffnet in Ihrem Browser eine Webseite mit dem Ergebnis der Abmeldung.

 

Sie können jetzt auf jedem System einen manuellen Schlüssel (einen, der keine Internetaktivierung erfordert) generieren, vorausgesetzt, Sie verfügen über den ursprünglichen Aktivierungsschlüssel und den Namen des Computers, dessen Registrierung Sie aufheben möchten, und das System, auf dem Sie den Schlüssel anfordern, verfügt über Internetzugang. Der Registrierungsdialog verfügt über ein Feld „Systemname“ für den Computernamen (standardmäßig wird das aktuelle System verwendet). Geben Sie den Namen ein und klicken Sie auf die Schaltfläche „Manuellen Schlüssel anfordern“. TCC öffnet eine Webseite in Ihrem Browser, die den manuellen Schlüssel zurückgibt. Kopieren Sie diesen Schlüsselwert und geben Sie ihn im Feld „Aktivierungsschlüssel“ im Registrierungsdialog ein.

 

Sie können nun Ihre Lizenzinformationen auf dem Registrierungsserver anzeigen. Rufen Sie den Registrierungsdialog auf, geben Sie Ihren Aktivierungsschlüssel ein und klicken Sie auf die Schaltfläche „Lizenzinformationen anzeigen“. TCMD öffnet in Ihrem Browser eine Webseite, auf der die maximale Anzahl der Systeme, die Sie registrieren können, die Namen der registrierten Systeme und das Datum ihrer Registrierung angezeigt werden.

 

Der Platzhalter [ ] akzeptiert jetzt beides ! or ^ als NOT-Symbol.

 

Die Popup-Fenster „Verlauf“ und „Verzeichnisverlauf“ unterstützen jetzt die Mehrfachauswahl (mit der Umschalt- oder Strg-Taste + linker Maus) und verfügen über ein Popup-Kontextmenü (rechte Maustaste) zum Kopieren, Kopieren+Anhängen, Ausschneiden oder Löschen. Sie können auch mehrere Einträge auswählen und diese durch Drücken der Eingabetaste ausführen. TCC erstellt eine Befehlszeile, die so aussieht:

 

(line1) & (line2) & (line3)

 

Es gibt neue Optionen zur Ausgabeumleitung. Diese Optionen überschreiben die UnicodeOutput- und UTF8Output-Direktiven in TCMD.INI. Die Piped-Ausgabeoptionen funktionieren auch mit DOS-Pipes (d. h. |!:u). Hinweis: Diese Optionen funktionieren nur für die Umleitung der Ausgabe von TCC interne Befehle.

 

>:aDie umgeleitete Ausgabe (STDOUT und/oder STDERR) ist ANSI (8-Bit-Zeichen).
>:uDie umgeleitete Ausgabe ist UTF16 Unicode
>:8 oder >:u8Die umgeleitete Ausgabe ist UTF8

 

>>:aAngehängte umgeleitete Ausgabe (STDOUT und/oder STDERR) ist ANSI (8-Bit-Zeichen)
>>:uDie angehängte umgeleitete Ausgabe ist UTF16 Unicode
>>:8 oder >>:u8Die angehängte umgeleitete Ausgabe ist UTF8

 

|:aDie weitergeleitete Ausgabe ist ANSI
|:uDie weitergeleitete Ausgabe ist UTF16 Unicode
|:8 oder |:u8Die weitergeleitete Ausgabe ist UTF8

 

Die Verzeichniseinfärbung (DIR, PDIR, SELECT) unterstützt jetzt Bereiche in der Variablen COLORDIR oder der INI-Direktive ColorDir. Weitere Informationen finden Sie unten im DIR.

 

Die Verzeichniseinfärbung (DIR, PDIR, SELECT) unterstützt jetzt Subsystemtypen (Win32, Win64, GUI, CUI) in der Variable COLORDIR oder der INI-Direktive ColorDir. Weitere Informationen finden Sie unten im DIR.

 

Datums- und Zeitbereiche können jetzt UTC-Zeiten vergleichen, indem in der Bereichsspezifikation ein „U“ nach dem D oder T (und dem optionalen A, C oder W) hinzugefügt wird. Zum Beispiel:

 

/[twu00:00,11:59]

 

Größenbereiche können jetzt die komprimierte Größe testen (auf NTFS-Laufwerken mit aktivierter Komprimierung für die Datei oder das Verzeichnis), indem ein C an das S-Argument angehängt wird. Um beispielsweise Dateien mit einer komprimierten Größe zwischen 100 und 1000 Byte anzugeben:

 

/[sc100,1000]

 

Der reguläre Ausdrucksanalysator (Strg-F7) verfügt jetzt über einen Mikrosekunden-Timer (rechts neben dem Bearbeitungssteuerelement „Test“), der die Zeit misst, die zum Auswerten des Ausdrucks benötigt wurde.

 

Der Regular Expression Analyzer verfügt über einen „Spickzettel“ mit RE-Syntax und allgemeinen Ausdrücken.

 

Sie können die verschieben TCC Fenster nach oben aus der Anzeige („Quake-Konsole“) und wieder nach unten mit Strg-Alt-Eingabetaste. Die Tastenfolge kann mit der QuakeHotKey .INI-Direktive konfiguriert werden; siehe unten.

 

Sie können das minimieren TCC Mit Strg-Umschalt-Z können Sie das Fenster in die Taskleiste verschieben und aus der Taskleiste entfernen. Die Tastenfolge kann mit der TrayHotKey .INI-Direktive konfiguriert werden; siehe unten.

 

Die CPU-Auslastung wurde reduziert TCC leicht beim Einfahren Take Command Tab-Fenster.

 

TCC erkennt, ob es als Dienst oder getrennt ausgeführt wird, bevor es zur SSL- oder SSH-Authentifizierung auffordert, und gibt automatisch eine „Y“-Eingabe (Ja) aus.

 

Die FileCompletion .INI-Direktive und die Umgebungsvariable unterstützen einen neuen Typ:

 

Bibliotheken – Tab-Vervollständigung für Bibliotheksfunktionsnamen

 

 

IDE / Batch-Debugger:

 

Das Scintilla-Bearbeitungssteuerelement wurde auf Version 4.2.0 aktualisiert.

 

Das Neuzeichnen in den Bearbeitungsfenstern erfolgt reibungsloser und schneller.

 

Die Lade- und Speicherzeiten für große Dateien wurden verbessert.

 

Beim Laden einer Datei prüft die IDE zunächst den Dateityp (UTF-16, UTF-8, UTF-8 mit BOM oder ANSI). Wenn die Datei keine UTF-16- oder UTF-8-Stückliste hat, wird sie als ANSI-Datei mit der aktuellen Konsolencodepage gelesen und vor der Bearbeitung in UTF-8 konvertiert. Beim Speichern wird es wieder in eine ANSI-Datei mit der aktuellen Codepage konvertiert. Dadurch kann die IDE High-Bit-ASCII-Zeichen im Editor korrekt anzeigen.

 

Der Batch-Debugger verfügt über einen neuen „Befehl Erweiterung"-Fenster, das über dem Registerkartenfenster angezeigt wird, wenn Sie mit dem Debuggen beginnen. Der Befehl Erweiterung Das Fenster zeigt die ursprüngliche Befehlszeile, die Befehlszeile nach der Alias-Erweiterung und die Befehlszeile nach der Variablenerweiterung. Der Befehl Erweiterung Das Fenster ist ein Andockfenster und kann daher verschoben und an anderen Orten angebracht werden. Wenn Sie den Befehl nicht sehen möchten Erweiterung Fenster können Sie es über die Menüoption „Ansicht/Befehlserweiterung“ der IDE deaktivieren.

 

Sie können jetzt in Einzelschritten in Befehlsgruppen und FOR-Schleifen einsteigen. Klicken Sie in der IDE-Symbolleiste auf die Schaltfläche „Einsteigen“. Im Fenster „Befehlserweiterung“ (siehe oben) sehen Sie, wie die aktuelle Befehlszeile ausgeführt wird.

 

Die Registerkarte „Geändert“ verfügt über eine neue Spalte „Vorherige“, die den vorherigen Wert der Variablen anzeigt, die gerade geändert wurde.

 

Beim Debuggen behält das IDE-Fenster jetzt die aktuelle Zeile in der Mitte des Bildschirms bei (es sei denn, sie befindet sich auf der letzten Seite). Dadurch können Sie sowohl die letzten als auch die nächsten auszuführenden Zeilen sehen.

 

Sie können die Transparenz des IDE-Fensters mit Strg-Umschalt-Mausrad ändern.

 

Die Fenster „Überwachen“, „Geändert“ und „Haltepunkt“ speichern jetzt die Spaltenbreiten, wenn Sie sie ändern, und verwenden die neuen Breiten, wenn Sie die IDE neu starten.

 

Im Bearbeitungsfenster bleibt die aktuelle Zeile jetzt hervorgehoben, auch wenn sie nicht im Fokus ist.

 

Das Bearbeitungsfenster behält standardmäßig die gleiche Einrückung wie in der vorherigen Zeile bei. Der Standardwert kann mit der Option MaintainIndent in TCMD.INI geändert werden (siehe unten).

 

Die Suche nach regulären Ausdrücken (Dialogfeld „Suchen“) verwendet jetzt die C++11-Bibliothek für reguläre Ausdrücke anstelle der vorherigen eingeschränkten Unterstützung für reguläre Ausdrücke.

 

Der Profiler-Timer verwendet jetzt die Windows-Leistungsindikatoren. Die Auflösung beträgt jetzt Millisekunden (001 Sekunden) statt Hundertstel (01 Sekunden).

 

Wenn Sie TCC Syntax (nicht CMD), und der erste Befehl in der Zeile ist ein interner TCC Wenn Sie den Befehl ausführen, zeigt die IDE die Schnellhilfe zur Verwendung in der Statusleiste an.

 

Dem Dateimenü wurde ein neues Untermenü hinzugefügt:

 

CodierungDateien werden im Editor immer als UTF-8 behandelt. Mit dieser Option können Sie festlegen, wie die Datei geschrieben wird, wenn sie auf der Festplatte gespeichert wird.        

 

Standard-CodepageWenn die Datei gespeichert wird, wird sie mit der aktuellen Codepage geschrieben
UTF16 Little EndianWenn die Datei gespeichert wird, wird sie als UTF-16 geschrieben
UtfxnumxWenn die Datei gespeichert wird, wird sie als UTF-8 geschrieben
UTF8 mit StücklisteWenn die Datei gespeichert wird, wird sie als UTF-8 mit einer führenden Stückliste geschrieben

 

Dem Menü „Bearbeiten“ wurde ein neuer Eintrag hinzugefügt:

 

Kopieren+AnhängenHängen Sie die aktuelle Auswahl an den vorhandenen Inhalt der Zwischenablage an.

 

Dem Bearbeiten-Menü wurde ein neues Untermenü hinzugefügt:

 

Zeilenendezeichen

 

CR + LFZeilen enden mit einem Wagenrücklauf + Zeilenvorschub (Windows-Standard)
CRZeilen enden mit einem Wagenrücklauf (OSX-Standard)
LFZeilen enden mit einem Linefeed  (Linux-Standard)

 

Dem Menü Bearbeiten / Erweitert wurde ein neuer Eintrag hinzugefügt:

 

Aktuelle Faltung umschalten – schaltet die Faltung der aktuellen Zeile ein und aus

 

Dem Menü „Ansicht“ wurden zwei neue Falteinträge hinzugefügt. (Dies wird etwas verwirrend sein, wenn Sie den Faltrand im Menü „Optionen“ nicht aktivieren!)

 

Aktuelle Faltung umschalten – schaltet die Faltung der aktuellen Zeile ein und aus

Alle Faltungen umschalten – schaltet jede Faltung in der Datei um

 

Dem Debug-Menü wurde ein neuer Eintrag hinzugefügt:

 

Befehl auswerten – führt den angegebenen Befehl im Kontext der aktuell ausgeführten Batchdatei aus. Die Ausgabe wird in einem scrollbaren, schreibgeschützten Bearbeitungssteuerelement angezeigt. Beachten Sie, dass der von Ihnen ausgeführte Befehl möglicherweise das Ergebnis der zu debuggenden Batchdatei ändert.

 

Das Rechtsklick-Kontextmenü des Registerkartenfensters verfügt über eine neue Option: „Kopieren+Anhängen“ hängt die aktuelle Auswahl an den vorhandenen Inhalt der Zwischenablage an.

 

Mit der Tastenkombination Strg-Umschalt-C wird die aktuelle Auswahl an den vorhandenen Inhalt der Zwischenablage angehängt.

 

Der reguläre Ausdrucksanalysator (Extras/Reguläre Ausdrücke...) verfügt jetzt über einen Mikrosekunden-Timer (rechts neben dem Bearbeitungssteuerelement „Test“), der die Zeit misst, die zum Auswerten des Ausdrucks benötigt wurde.

 

Der Regular Expression Analyzer verfügt über einen „Spickzettel“ mit RE-Syntax und allgemeinen Ausdrücken.

 

Die Fenster „Überwachen“, „Geändert“ und „Haltepunkte“ zeigen jetzt beim Bewegen der Maus einen Tooltip an, der den vollständigen Text einer Spalte enthält, wenn dieser zu breit ist, um vollständig in der Spalte angezeigt zu werden.

 

Wenn Sie „aussteigen“ (bis zum Haltepunkt oder Ende ausführen) und sich in einer CALL-Batchdatei befinden und in der aktuellen Datei keine weiteren Haltepunkte vorhanden sind, kehren Sie in der folgenden Zeile zur übergeordneten Batchdatei zurück ANRUF und „Aussteigen“ werden ausgeschaltet.

 

Der Debugger speichert keine *.watch-Datei, wenn die einzigen überwachten Variablen die Standardvariablen sind ? und _?.

 

 

TCEDIT:

 

Das Scintilla-Bearbeitungssteuerelement wurde auf Version 4.2.0 aktualisiert.

 

Verbessert die TCEdit Startzeit.

 

Die Lade- und Speicherzeiten für große Dateien wurden verbessert.

 

Beim Laden einer Datei TCEdit prüft zunächst den Dateityp (UTF-16, UTF8, UTF-8 mit BOM oder ANSI). Wenn die Datei keine UTF-16- oder UTF-8-Stückliste hat, wird sie als ANSI-Datei mit der aktuellen Konsolencodepage gelesen und vor der Bearbeitung in UTF-8 konvertiert. Beim Speichern wird es wieder in eine ANSI-Datei mit der aktuellen Codepage konvertiert. Dies erlaubt TCEdit um High-Bit-ASCII-Zeichen richtig anzuzeigen.

 

Das Neuzeichnen in den Bearbeitungsfenstern erfolgt reibungsloser und schneller.

 

Sie können das ändern TCEdit Fenstertransparenz mit Strg-Umschalt-Mausrad.

 

Im Bearbeitungsfenster bleibt die aktuelle Zeile jetzt hervorgehoben, auch wenn sie nicht im Fokus ist.

 

Das Bearbeitungsfenster behält standardmäßig die gleiche Einrückung wie in der vorherigen Zeile bei. Der Standardwert kann mit der Option MaintainIndent in TCMD.INI geändert werden (siehe unten).

 

Die Suche nach regulären Ausdrücken (Dialogfeld „Suchen“) verwendet jetzt die C++11-Bibliothek für reguläre Ausdrücke anstelle der vorherigen eingeschränkten Unterstützung für reguläre Ausdrücke.

 

Dem Dateimenü wurde ein neues Untermenü hinzugefügt:

 

CodierungDateien werden im Editor immer als UTF-8 behandelt. Mit dieser Option können Sie festlegen, wie die Datei geschrieben wird, wenn sie auf der Festplatte gespeichert wird.        

 

Standard-CodepageWenn die Datei gespeichert wird, wird sie mit der aktuellen Codepage geschrieben
UTF16 Little EndianWenn die Datei gespeichert wird, wird sie als UTF-16 geschrieben
UtfxnumxWenn die Datei gespeichert wird, wird sie als UTF-8 geschrieben
UTF8 mit StücklisteWenn die Datei gespeichert wird, wird sie als UTF-8 mit einer führenden Stückliste geschrieben

 

Dem Menü „Bearbeiten“ wurde ein neuer Eintrag hinzugefügt:

 

Kopieren+AnhängenHängen Sie die aktuelle Auswahl an den vorhandenen Inhalt der Zwischenablage an.

 

Dem Bearbeiten-Menü wurde ein neues Untermenü hinzugefügt:

 

Zeilenendezeichen

 

CR + LFZeilen enden mit einem Wagenrücklauf + Zeilenvorschub (Windows-Standard)
CRZeilen enden mit einem Wagenrücklauf (OSX-Standard)
LFZeilen enden mit einem Linefeed  (Linux-Standard)

 

Dem Menü Bearbeiten / Erweitert wurde ein neuer Eintrag hinzugefügt:

 

Aktuelle Faltung umschalten – schaltet die Faltung der aktuellen Zeile ein und aus

 

Dem Menü „Ansicht“ wurden zwei neue Falteinträge hinzugefügt. (Dies wird etwas verwirrend sein, wenn Sie den Faltrand im Menü „Optionen“ nicht aktivieren!)

 

Aktuelle Faltung umschalten – schaltet die Faltung der aktuellen Zeile ein und aus

Alle Faltungen umschalten – schaltet jede Faltung in der Datei um

 

Das Rechtsklick-Kontextmenü des Registerkartenfensters verfügt über eine neue Option: „Kopieren+Anhängen“ hängt die aktuelle Auswahl an den vorhandenen Inhalt der Zwischenablage an.

 

Mit der Tastenkombination Strg-Umschalt-C wird die aktuelle Auswahl an den vorhandenen Inhalt der Zwischenablage angehängt.

 

 

Hilfe:

 

Die Hilfe wurde mit einer neuen Version von Help & Manual 7 erstellt.

 

 

TMCD.INI-Anweisungen:

 

CursorLineColor – Legen Sie die Farbe der Linie fest, in der sich der Cursor befindet (nur TCMD-Registerkartenfenster). Stellen Sie es mit OPTIONS / ein. Take Command / Tabs / Windows / Cursorzeile.

 

EscResetHistory=yes|NO – Wenn JA, TCC setzt den Befehlsverlaufszeiger an das Ende der Liste zurück, wenn Sie an der Eingabeaufforderung eine Escape-Taste drücken.

 

MaintainIndent=YES|no – In IDE & TCEdit Verwenden Sie in Bearbeitungsfenstern denselben Einzug wie in der vorherigen Zeile.

 

QuakeHotKey (Standard-Eingabetaste) – Hotkey zum Verschieben des Take Command or TCC Windows „Quake-Stil“. Der Hotkey ist immer Strg-Alt – irgendetwas; Der Wert für QuakeHotKey ist der letzte Wert. Zum Beispiel für die Standardeinstellung Strg-Alt-Eingabetaste::

 

QuakeHotKey=Enter

 

RepeatArgument – ​​Dupliziert das vorherige Argument in der Befehlszeile (standardmäßig Umschalt-F12).

 

ScreenUpdate – Anzahl der Bilder pro Sekunde für Take Command Registerkarte Windows-Updates. Der Bereich liegt zwischen 1 und 100; Der Standardwert ist 30.

 

TrayHotKey (Standard Strg-Umschalt-Z) – Verschieben Sie die Take Command or TCC Fenster in und aus der Taskleiste.

 

Der Abschnitt (veraltet, veraltet, nicht empfohlen) [Sekundär] wurde aktiviert.

 

 

Befehlszeilenbearbeitung:

 

Problemumgehung für Windows 10-Fehler hinzugefügt, um die Verwendung von Auswahltastenanschlägen (z. B. Umschalt-Links usw.) zu ermöglichen, ohne die Legacy-Konsole zu aktivieren.

 

Umschalt-F12 (RepeatArgument) dupliziert das vorherige Argument in der Befehlszeile.

 

Strg-Rücktaste – dasselbe wie Strg-L (Wort links löschen).

 

Strg-Entf – dasselbe wie Strg-R (Wort rechts löschen).

 

Die Standardeinstellung wurde geändert TCC „Rückgängig machen“-Bearbeitungstaste von Alt-Z zu Strg-Umschalt-Z (Windows 10 frisst die Alt-Z-Taste, es sei denn, Sie legen die Option „Legacy-Konsole“ fest.)

 

Die Standardeinstellung wurde geändert TCC „Wiederherstellen“-Bearbeitungstaste von Alt-Y auf Strg-Umschalt-Y (Windows 10 frisst die Alt-Y-Taste, es sei denn, Sie legen die Option „Legacy-Konsole“ fest.)

 

 

Neue interne Variablen:

 

Es gibt eine Reihe neuer interner Variablen für GPS-Position und -Status. Sie erfordern ein GPS (intern oder extern), das die Windows Sensor Location APIs unterstützt. Beachten Sie, dass Ihr GPS möglicherweise nicht alle Variablen unterstützt; Wenn ein Wert nicht unterstützt wird, gibt Windows „Element nicht gefunden“ zurück. Sofern nicht anders angegeben, handelt es sich bei den zurückgegebenen Werten um Dezimalzahlen (z. B. 38.735122).

 

%_gpsalt – Höhe (vom Meeresspiegel aus) in Metern.

 

%_gpsazimuth – Azimut jedes Satelliten im Sichtfeld. Gibt eine durch Leerzeichen getrennte Liste zurück.

 

%_gpselevation – Höhe jedes sichtbaren Satelliten. Gibt eine durch Leerzeichen getrennte Liste zurück.

 

%_gpserrorradius – Genauigkeit der Breiten- und Längengrade in Metern.

 

%_gpsfixquality – Qualität des Fixes (Ganzzahl).

 

%_gpsfixtype – Typ des Fixes (Ganzzahl).

 

%_gpshdop – Horizontale Verdünnung der Präzision.

 

%_gpsheading – Wahrer Kurs.

 

%_gpsids – IDs der angezeigten Satelliten. Gibt eine durch Leerzeichen getrennte Liste von Ganzzahlen zurück.

 

%_gpslat – Breitengrad

 

%_gpslon – Längengrad

 

%_gpsmagheading – Magnetischer Kurs.

 

%_gpsnmea – Gibt den NMEA-Satz als Zeichenfolge zurück.

 

%_gpsopmode – GPS-Betriebsmodus (Ganzzahl).

 

%_gpspdop – Positionsverdünnung der Präzision.

 

%_gpsprns – PRN-Anzahl der sichtbaren Satelliten. Gibt eine durch Leerzeichen getrennte Liste von Ganzzahlen zurück.

 

%_gpssatsinview – Anzahl der sichtbaren Satelliten (Ganzzahl)

 

%_gpssatsused – Anzahl der in der Lösung verwendeten Satelliten (Ganzzahl).

 

%_gpsselmode – GPS-Auswahlmodus (Ganzzahl).

 

%_gpssnr – Signal-Rausch-Verhältnis jedes sichtbaren Satelliten. Gibt eine durch Leerzeichen getrennte Liste zurück.

 

%_gpsspeed – Geschwindigkeit in Knoten.

 

%_gpsstatus – GPS-Status (Ganzzahl).

 

%_gpsvdop – Vertikale Verdünnung der Präzision.

 

 

Neue Variablenfunktionen:

 

@VARTYPE – Gibt den Typ (falls vorhanden) für den angegebenen Variablennamen zurück. Die möglichen Werte sind:

 

0Kein Typ
1Ganzzahl (0-9)
2Dezimal (0-9, das Dezimalzeichen und das Tausendertrennzeichen)
3Hex (0-9, AF)
4Boolescher Wert (0 oder 1)
5Alphabetisch (A-Z und a-z)
6Alphanumerisch (A-Z, a-z und 0-9)
7Regulären Ausdruck

 

@WINPATH - Konvertieren vom WSL-Pfadnamenformat in das Windows-Format. Zum Beispiel:

 

Echo %@winpath[//mnt/c/windows/system32/notepad.exe]

c:\windows\system32\notepad.exe

 

@WSLPATH - Konvertieren vom Windows-Pfadnamenformat in das WSL-Format. Zum Beispiel:

 

Echo %@wslpath[c:\windows\system32\notepad.exe]

//mnt/c/windows/system32/notepad.exe

 

 

Aktualisierte Variablenfunktionen:

 

@EVAL - Funktion log2() hinzugefügt.

 

@PID – Ein optionales zweites Argument hinzugefügt, das angibt, ob alle PIDs zurückgegeben werden sollen, die mit dem ersten Argument übereinstimmen. Zum Beispiel:

 

@pid[firefox,+]

 

@TIMER – Verwendet jetzt die Windows-Leistungsindikatoren für eine höhere Auflösung. Die Standardauflösung von @TIMER beträgt Millisekunden (001 Sekunden) statt Hundertstel (0.01 Sekunden). @TIMER hat drei neue Werte für das optionale zweite Argument, um die Zwischenzeit als arithmetischen Wert zurückzugeben:

 

ms – Zwischenzeit in Millisekunden

us - Zwischenzeit in Mikrosekunden

ns – Zwischenzeit in Nanosekunden

 

@AUSFÜHRUNG - Ein neuer optionaler fünfter Parameter wurde hinzugefügt, der angibt, ob die Versionsnummer an den Dateinamen angehängt werden soll (5) oder der Erweiterung vorangestellt werden soll (0).

 

 

Plugins:

 

Plugins können jetzt jeden Befehl (Alias, intern, Batchdatei usw.) ausführen, ohne dass es zu Konflikten mit dem Hauptbefehl kommt TCC Verarbeitungsthread (siehe TCC über).

 

 

Aktualisierte Befehle:

 

AKTIVIEREN

 

/POS – akzeptiert a * Wert für eines der Argumente. Wenn der Wert ist *, ACTIVATE verwendet den vorhandenen Positions-/Breite-/Höhenwert. Um beispielsweise die Größe eines Fensters zu ändern, ohne es zu verschieben:

 

AKTIVIEREN Sie „Titel“ /POS=*,*,1200,800

 

So verschieben Sie ein Fenster, ohne seine Größe zu ändern:

 

„Titel“ AKTIVIEREN /POS=200,400,*,*

 

ASSOZIIEREN

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

/V:verb- ASSOCIATE liest und schreibt standardmäßig in SHELL\OPEN\COMMAND. Sie können ein anderes Verb verwenden, indem Sie die Option /V angeben. Um beispielsweise anzuweisen, ein PRINT-Verb für TXT-Dateien zu erstellen:

 

ASSOCIATE /V:PRINT .txt=%%SystemRoot%%\system32\NOTEPAD.EXE /p %%1

 

ATTRIB

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

KWK

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

FARBE

 

COLOR unterstützt jetzt das Ändern der Konsolenfarbpalette entweder mit einer .INI-Datei (z. B. wie vom ColorTool-Dienstprogramm verwendet) oder einer .ITERMCOLORS-Datei. Die Syntax lautet:

 

COLOR /F-Dateiname

 

Wenn Sie in einem laufen Take Command Im Tab-Fenster übergibt COLOR die neuen Farben an TCMD, um das Tab-Fenster zu aktualisieren. Sie können in jedem Tab-Fenster eine andere Farbpalette verwenden.

 

DIR

 

Die Verzeichniseinfärbung (entweder mit der Umgebungsvariablen COLORDIR oder OPTION/Farben/Verzeichnisfarben) unterstützt jetzt alle Arten von Bereiche (Größe, Datum, Uhrzeit, Beschreibung, Eigentümer und Ausschluss). Die Syntax ist dieselbe wie für Bereiche in einem internen Befehl. Um beispielsweise Dateien mit einer Größe zwischen 100 und 1000 Byte in hellem Grün anzuzeigen:

 

set colordir=/[s100,1000]:bri green;

 

Die Verzeichniseinfärbung unterstützt jetzt Farben für Dateisubsystemtypen. Die unterstützten Subsysteme sind:

 

EXETYPE_WIN32GUIWindows x86 GUI-App
EXETYPE_WIN32CUIWindows x86-Konsolen-App
EXETYPE_WIN64GUIWindows x64 GUI-App
EXETYPE_WIN64GUIWindows x64-Konsolen-App
EXETYPE_DOSDOS-App (16-Bit) (veraltet)
EXETYPE_POSIXPOSIX-App (veraltet)
EXETYPE_EFIEFI-App

 

Um beispielsweise 32-Bit-Konsolen-Apps in leuchtendem Grün und 64-Bit-Konsolen-Apps in leuchtendem Rot anzuzeigen:

 

set colordir=EXETYPE_WIN32CUI:bri green;EXETYPE_WIN64CUI:bri red

 

/-C – Entfernt die Tausendertrennzeichen bei der Anzeige von Dateigrößen (für Kompatibilität mit CMD.EXE).

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

ENUMSERVER

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

ENUMSHARES

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

ALLES

 

Die Take Command / TCC Die Distribution enthält jetzt ES.EXE, die Befehlszeilenschnittstelle für ALLES (einschließlich einer x64-Version für x64-Windows).

 

FÜR

 

Das ~a-Format (Anzeigeattribute) wurde aktualisiert, um dem aktuellen CMD-Verhalten mit erweiterten Attributen zu entsprechen (einschließlich des CMD-Verhaltens, nicht alle erweiterten Attribute anzuzeigen).

 

GOSUB

 

GOSUB unterstützt jetzt den Aufruf von Unterprogrammen in einer anderen Datei, wenn diese Datei komprimiert ist.

 

KOPF

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

IF

 

ISVISIBLE „title“ – führt den Befehl aus, wenn das angegebene Fenster sichtbar ist. (Dies bedeutet, dass Windows das Sichtbarkeitsflag gesetzt hat; es bedeutet nicht, dass das Fenster unbedingt auf Ihrem Desktop sichtbar ist.

 

IFF

 

ISVISIBLE „title“ – führt den Befehl aus, wenn das angegebene Fenster sichtbar ist.

 

EINGERICHTET

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

BIBLIOTHEK

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

PAUSE

 

/C – Nach dem Drücken einer Taste wird die Eingabeaufforderung gelöscht und kein CR/LF gedruckt.

 

PDIR

 

Die Verzeichniseinfärbung unterstützt jetzt Bereiche (siehe DIR für Details).

 

Die Verzeichniseinfärbung unterstützt jetzt Subsystemtypen (Einzelheiten finden Sie im DIR).

 

/D – hat die Bedeutung von „einfärben“ in „nicht einfärben“ geändert (um mit DIR und SELECT übereinzustimmen).

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

PLUGIN

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

IHR EIGENES LOGO

 

/S Drucker - Legen Sie den Standarddrucker fest.

 

PRIORITY

 

Wenn Sie nur eine PID oder einen Fenstertitel angeben, zeigt PRIORITY die aktuelle Priorität an.

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

PROMPT

 

Die Auflösung des PROMPT-Timers (= Metazeichen) beträgt jetzt Millisekunden (001 Sekunden) statt Hundertstel (01 Sekunden).

 

REGDIR

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

/X – Zeigt die Werte REG_DWORD, REG_DWORD_BIG_ENDIAN und REG_QWORD im Hexadezimalformat an. Nur gültig bei Verwendung mit /V und /D.

 

SELECT

 

Die Verzeichniseinfärbung unterstützt jetzt Bereiche (siehe DIR für Details).

 

Die Verzeichniseinfärbung unterstützt jetzt Subsystemtypen (Einzelheiten finden Sie im DIR).

 

SERVICES

 

/I – Zeigt die PIDs für Dienste an. Beachten Sie, dass gestoppte Dienste ebenso wie Windows-Dienste den Wert 0 für die PID zurückgeben.

 

SYNC

 

/WAIT=n – Pause für n Millisekunden zwischen jedem Block, der von der Quelle in die Zieldatei kopiert wird. Dies ist nützlich für langsame Netzwerke und sehr große Dateikopien; Es verhindert, dass SYNC die gesamte Netzwerk-E/A monopolisiert.

 

TAIL

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

Aufgabenliste

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

TIMER

 

TIMER verwendet jetzt die Windows-Leistungsindikatoren für eine höhere Genauigkeit. Die standardmäßige TIMER-Auflösung beträgt jetzt Millisekunden (001 Sekunden) statt Hundertstel (0.01 Sekunden).

 

/L – Bei Verwendung mit /S (Zwischenzeit) oder TIMER OFF wird das Ergebnis in Millisekunden angezeigt.

 

/M – Bei Verwendung mit /S (Zwischenzeit) oder TIMER OFF wird das Ergebnis in Mikrosekunden angezeigt.

 

/N – Bei Verwendung mit /S (Spaltzeit) oder TIMER OFF wird das Ergebnis in Nanosekunden angezeigt.

 

BERÜHREN

 

/CD – erstellt das angegebene Verzeichnis, falls es nicht existiert.

 

TREE

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

TYP

 

/Pn – die Option /P(ause) hat ein optionales Argument n Gibt an, wie viele Sekunden auf einen Tastendruck gewartet werden soll, bevor fortgefahren wird.

 

UNQLITE

 

Aktualisiert auf UnQLite 1.1.9.

 

ANZEIGEN

 

DPI-Unterstützung pro Monitor (Windows 10 Creators Update 1703 und höher). Das bedeutet, dass sich V automatisch anpasst, wenn zwischen Monitoren unterschiedlicher Skalierung gewechselt wird.

Klicken Sie bei gedrückter Umschalttaste auf die CSV-Spaltenüberschrift, um die gesamte Spalte auszuwählen.

Befehl „CSV kopieren“, um CSV-Spalten (mit Trennzeichen) in die Zwischenablage zu kopieren.

Befehlszeilenoption /QUIET zum Drucken hinzugefügt.

 

FENSTER

 

/POS – akzeptiert a * Wert für eines der Argumente. Wenn der Wert ist *, WINDOW verwendet den vorhandenen Positions-/Breite-/Höhenwert. Um beispielsweise die Größe eines Fensters zu ändern, ohne es zu verschieben:

 

FENSTER /POS=*,*,1200,800

 

So verschieben Sie ein Fenster, ohne seine Größe zu ändern:

 

FENSTER /POS=200,400,*,*