Take Command 26.0:

 

Die Unterstützung von Windows 7 wurde von allen Produkten eingestellt (Take Command, TCC, CMDebug und TCC-RT).

 

Außer für TCC-RT, 32-Bit-Windows-Unterstützung ist in Version 26 veraltet. Die v26 Take Command, TCC und CMDebug Installationsprogramme sind alle nur 64-Bit. 32-Bit-Installationsprogramme sind auf Anfrage für Multisystemlizenzen verfügbar.

 

Der Cavalon Sentinel ist das AutoGyro-Premiummodell mit nebeneinander angeordneten Sitzen, verfügbar mit dem neuen hochmodernen und kraftstoffsparenden Rotax XNUMX iS-Motor. Take Command, TCC, CMDebug und TCC-RT-Installationsprogramme werden mit einer neuen Version von Advanced Installer erstellt.

 

 

Take Command:

 

Alles geändert Take Command Symbole zu einem modernen „Fluent“-Design.

 

Die GUI-Framework-Bibliothek wurde aktualisiert.

 

Die Sprach-DLLs sind wesentlich kleiner und werden schneller geladen.

 

Viele Leistungs- und Größenverbesserungen.

 

Take Command wird jetzt richtig skaliert, wenn zwischen Monitoren mit unterschiedlichen DPI-Werten gewechselt wird.

 

Unterstützung für Windows Server 2019 hinzugefügt.

 

Das Windows-Fehlersuchtool unterstützt jetzt NTSTATUS-Fehlercodes.

 

Im Menü „Optionen“ gibt es eine neue Option zum Ändern des Arbeitsverzeichnisses Take Command.

 

Das Kontextmenü auf den Tab-Beschriftungen verfügt über einen neuen Eintrag „Suchen“, um das aktuelle Tab-Fenster zu durchsuchen.

 

Das Kontextbearbeitungsmenü im Tab-Fenster verfügt über einen neuen Eintrag „Suchen“, um das aktuelle Tab-Fenster zu durchsuchen.

 

Im Dialogfeld „Ausführen“ stehen neue Optionen zur Auswahl TCC, CMD, PowerShell oder Bash.

 

Das Dialogsymbol „Ausführen“ wurde zum Schnellzugriffsmenü hinzugefügt Take Command Titelleiste.

 

Der Dialog „Ausführen“ wurde zum HOME-Menü hinzugefügt.

 

Der Cavalon Sentinel ist das AutoGyro-Premiummodell mit nebeneinander angeordneten Sitzen, verfügbar mit dem neuen hochmodernen und kraftstoffsparenden Rotax XNUMX iS-Motor. Take Command Dialoge wurden optimiert, um übersichtlicher und besser lesbar zu sein.

 

Der Tooltip für den Transparenz-Schieberegler (untere rechte Ecke) zeigt jetzt die aktuelle Transparenzeinstellung an (20 – 255; höhere Werte sind undurchsichtiger).

 

 

TCC:

 

Everything Search wurde auf 1.4.1.969 aktualisiert.

 

Die Sprach-DLLs sind wesentlich kleiner und werden schneller geladen.

 

Viele Leistungs- und Größenverbesserungen.

 

Der eingebettete Lua-Interpreter wurde auf Version 5.4 aktualisiert.

 

Die Python-Unterstützung wurde mit der neuen Version 3.8.2 neu aufgebaut.

 

Unterstützung für Windows Server 2019 hinzugefügt.

 

Die meisten der verbleibenden Zeichenfolgegrößenbeschränkungen wurden entfernt (mit Ausnahme derjenigen, bei denen die Windows-APIs Beschränkungen haben).

 

TCC Unterstützt jetzt sowohl lokale als auch globale Aliaslisten (oder keine von beiden) gleichzeitig. TCC sucht zuerst in der lokalen Liste (falls vorhanden) nach einer Übereinstimmung; Wenn keines gefunden wird, wird in der globalen Liste gesucht. Dies ermöglicht Ihnen einen gemeinsamen Satz von Aliasen (in der globalen Liste) und aufgabenspezifischen Aliasen (in der lokalen Liste). Mit den Optionen ALIAS /GL und /LL können Sie angeben, welche Liste Sie beim Anzeigen/Erstellen/Ändern/Löschen von Aliasen verwenden möchten.

 

TCC Unterstützt jetzt sowohl lokale als auch globale benutzerdefinierte Funktionslisten (oder keine von beiden) gleichzeitig. TCC sucht zuerst in der lokalen Liste (falls vorhanden) nach einer Übereinstimmung; Wenn keines gefunden wird, wird in der globalen Liste gesucht. Dies ermöglicht Ihnen einen gemeinsamen Satz von Funktionen (in der globalen Liste) und aufgabenspezifischen Funktionen (in der lokalen Liste). Mit den Optionen FUNCTION /GL und /LL können Sie angeben, welche Liste Sie beim Anzeigen/Erstellen/Ändern/Löschen von Funktionen verwenden möchten.

 

TCC Unterstützt jetzt sowohl lokale als auch globale Befehlsverlaufslisten gleichzeitig. Dies ist nur für fortgeschrittene Benutzer; Es wird im Allgemeinen nicht empfohlen, beide Typen zu verwenden. Wenn Sie nur über eine lokale Befehlsverlaufsliste oder nur eine globale Befehlsverlaufsliste verfügen, funktioniert der Verlaufsabruf genauso wie in früheren Versionen. Wenn Sie sowohl lokale als auch globale Befehlsverlaufslisten haben, wird bei der Rückwärtssuche im Verlauf zunächst die lokale Liste durchsucht. Wenn Sie den Anfang der lokalen Liste erreichen, stammt der nächste zurückgegebene Verlaufseintrag vom Ende der globalen Liste. Wenn Sie die globale Liste vorwärts durchsuchen, ist der nächste zurückgegebene Verlaufseintrag am Ende der Anfang der lokalen Liste, wenn Sie das Ende erreichen. Wenn Sie versuchen, über den Anfang der globalen Liste oder das Ende der lokalen Liste hinauszugehen TCC wird piepen. Beachten Sie, dass der Verlaufsumbruch nicht mit lokalen und globalen Listen kompatibel ist.

 

TCC Unterstützt jetzt sowohl lokale als auch globale Verzeichnisverlaufslisten gleichzeitig. Dies ist nur für fortgeschrittene Benutzer; Es wird im Allgemeinen nicht empfohlen, beide Typen zu verwenden. Wenn Sie nur über eine lokale Verzeichnisverlaufsliste oder nur eine globale Verzeichnisverlaufsliste verfügen, funktioniert das Abrufen des Verzeichnisverlaufs genauso wie in früheren Versionen. Wenn Sie sowohl lokale als auch globale Verzeichnisverlaufslisten haben, wird bei der Rückwärtssuche im Verlauf zunächst die lokale Liste durchsucht. Wenn Sie den Anfang der lokalen Liste erreichen, stammt der nächste zurückgegebene Verlaufseintrag vom Ende der globalen Liste. Wenn Sie die globale Liste vorwärts durchsuchen, ist der nächste zurückgegebene Verlaufseintrag am Ende der Anfang der lokalen Liste, wenn Sie das Ende erreichen. Wenn Sie versuchen, über den Anfang der globalen Liste oder das Ende der lokalen Liste hinauszugehen TCC wird piepen.

 

Zwei optionale spezielle Aliase hinzugefügt, mit denen Sie Ihre Umgebung basierend auf dem aktuellen Verzeichnis anpassen können:

 

CD_Leave - TCC führt diesen Alias ​​aus, wenn das aktuelle Verzeichnis geändert werden soll. TCC übergibt den Namen des aktuellen Verzeichnisses (%1) und den Namen des neuen Verzeichnisses (%2).

 

CD_Enter - TCC führt diesen Alias ​​sofort nach dem Wechsel des aktuellen Verzeichnisses aus. TCC übergibt den Namen des neuen Verzeichnisses (%1).

 

 

IDE / Batch-Debugger:

 

Die GUI-Framework-Bibliothek wurde aktualisiert.

 

Die IDE skaliert jetzt ordnungsgemäß, wenn zwischen Monitoren mit unterschiedlichen DPI-Werten gewechselt wird.

 

Das Scintilla-Bearbeitungssteuerelement wurde auf Version 4.3.2 aktualisiert.

 

Viele Leistungs- und Größenverbesserungen.

 

Die Hilfe für die IDE/den Debugger wurde erweitert.

 

Die IDE überwacht das Dateisystem auf Änderungen an den bearbeiteten Dateien. Wenn eine andere Anwendung eine Datei ändert, zeigt die IDE eine Meldung an, die Sie über die Änderung informiert und fragt, ob Sie die aktualisierte Datei neu laden möchten.

 

Alle IDE-Symbole wurden in ein modernes „Fluent“-Design geändert.

 

Die meisten IDE-Menüeinträge verfügen über Symbole, die Ihnen mehr Optionen zum Anpassen der Symbolleiste bieten.

 

Die Schriftartenanzeige wurde leicht verbessert.

 

Nach dem Dateinamen gibt es eine neue Startoption, um zu einer Zeilennummer zu gelangen:

 

/gotoline:nn

 

Beispielsweise:

 

bdebugger mytest.cmd /gotoline:24 [Batchdateiargumente...]

 

Im Menü „Optionen“ gibt es eine neue Option „Syntaxfarben“, mit der Sie aus einer 16-Millionen-Farbpalette die für die Syntaxkolorierung verwendeten Farben auswählen können. Wenn Sie auf eine der Schaltflächen für die Vordergrund- oder Hintergrundfarbe klicken, zeigt die IDE einen Farbauswahldialog an, in dem Sie Farben auswählen können.

 

Das Dialogfeld „Fehlersuche“ (Debug / Fehlersuche) unterstützt jetzt NTSTATUS-Fehlercodes.

 

Die IDE verfügt über zusätzliche Registerkarten für lokale Aliase, globale Aliase, lokale Funktionen und globale Funktionen. Sie werden nur angezeigt, wenn die entsprechende lokale/globale Liste vorhanden ist.

 

Es gibt eine neue Option im Menü „Datei“, mit der Sie die Datei im aktuellen Tab von der Festplatte neu laden können.

 

Im Menü „Datei“ gibt es eine neue Option zum Löschen der Datei auf der aktuellen Registerkarte im Papierkorb.

 

Im Menü „Datei“ gibt es zwei neue Optionen zum Speichern und Laden von Sitzungen. Sie erstellen eine Sitzung mit der Menüoption „Sitzung speichern“, wodurch eine Datei mit den Namen der Dateien in den Registerkartenfenstern erstellt wird. „Sitzung laden“ öffnet die Dateien in der von Ihnen angegebenen *.session-Datei.

 

Im Menü „Optionen“ gibt es eine neue Option zum Festlegen der Caret-Farbe für die Tab-Bearbeitungsfenster.

 

Im Menü „Optionen“ gibt es eine neue Option zum Ändern des Arbeitsverzeichnisses für die IDE.

 

Im Menü „Optionen“ gibt es ein neues Untermenü zur Auswahl der Position der Fensterregisterkarte (oben, unten, links oder rechts).

 

Das Kontextmenü auf den Registerkartenbezeichnungen verfügt über einen neuen Eintrag „Vollständigen Pfad kopieren“, der den vollständigen Pfadnamen der Datei in dieser Registerkarte in die Zwischenablage kopiert.

 

Das Kontextmenü auf den Tab-Beschriftungen verfügt über einen neuen Eintrag „Alle schließen“, der alle Tab-Fenster schließt.

 

Der Menüeintrag „Registerkarten…“ wurde von „Optionen“ in „Bearbeiten“ verschoben.

 

Die IDE-Dialoge wurden optimiert, um übersichtlicher und besser lesbar zu sein.

 

Der Tooltip für den Transparenz-Schieberegler (untere rechte Ecke) zeigt jetzt die aktuelle Transparenzeinstellung an (20 – 255; höhere Werte sind undurchsichtiger).

 

Das Kombinationsfeld „Stapelargumente“ in der IDE-Symbolleiste zeigt jetzt einen Hinweistext an, wenn Sie beim Start keine Argumente angeben.

 

Wenn Sie Text in ein Bearbeitungsfenster ziehen, wird das Fenster jetzt automatisch gescrollt, wenn Sie die Ränder erreichen.

 

Der Unicode-Wert in der Statusleiste für das Zeichen an der Cursorposition unterstützt jetzt UTF8-Multibyte-Zeichen.

 

Unterstützung für UTF8 in TCMD.INI hinzugefügt.

 

 

TCEDIT:

 

Die GUI-Framework-Bibliothek wurde aktualisiert.

 

TCEdit wird jetzt richtig skaliert, wenn zwischen Monitoren mit unterschiedlichen DPI-Werten gewechselt wird.

 

Das Scintilla-Bearbeitungssteuerelement wurde auf Version 4.3.2 aktualisiert.

 

Viele Leistungs- und Größenverbesserungen.

 

Die Hilfe für wurde erweitert TCEdit.

 

TCEdit überwacht das Dateisystem auf Änderungen an den bearbeiteten Dateien. Wenn eine andere Anwendung eine Datei ändert, zeigt die IDE eine Meldung an, die Sie über die Änderung informiert und fragt, ob Sie die aktualisierte Datei neu laden möchten.

 

Alles geändert TCEdit Symbole zu einem modernen „Fluent“-Design.

 

Die meisten der TCEdit Menüeinträge verfügen über Symbole, die Ihnen mehr Optionen zum Anpassen der Symbolleiste bieten.

 

Die Schriftartenanzeige wurde leicht verbessert.

 

TCEdit Unterstützt jetzt Piped-Eingabe. Beispiel: „dir | TCEdit" lädt den Inhalt des Verzeichnisses in das erste Tab-Fenster.

 

TCEdit Unterstützt jetzt die Piped-Ausgabe mit der Menüoption „Datei / Auf STDOUT speichern“. Dadurch können Sie die Pipe-Eingabe bearbeiten, bevor Sie sie zur Verarbeitung durch eine andere App weiterleiten. Zum Beispiel:

 

dir /b | tcedit | irgendjemand

 

Es gibt eine neue Befehlszeilenoption zum Drucken der Datei und zum anschließenden Beenden TCEdit:

 

tcedit Dateinamen /drucken

 

Nach dem Dateinamen gibt es eine neue Startoption, um zu einer Zeilennummer zu gelangen:

 

/gotoline:nn

 

Beispielsweise:

 

tcedit mytest.cmd /gotoline:24 [yourtest.cmd /gotoline:12 ...]

 

Es gibt eine neue Option im Menü „Datei“, mit der Sie die Datei im aktuellen Tab von der Festplatte neu laden können.

 

Im Menü „Datei“ gibt es eine neue Option zum Löschen der Datei auf der aktuellen Registerkarte im Papierkorb.

 

Im Menü „Datei“ gibt es zwei neue Optionen zum Speichern und Laden von Sitzungen. Sie erstellen eine Sitzung mit der Menüoption „Sitzung speichern“, wodurch eine Datei mit den Namen der Dateien in den Registerkartenfenstern erstellt wird. „Sitzung laden“ öffnet die Dateien in der von Ihnen angegebenen *.session-Datei.

 

Im Menü „Optionen“ gibt es eine neue Option „Syntaxfarben“, mit der Sie aus einer 16-Millionen-Farbpalette die für die Syntaxkolorierung verwendeten Farben auswählen können. Wenn Sie auf eine der Schaltflächen für die Vordergrund- oder Hintergrundfarbe klicken, wird TCEdit zeigt einen Farbauswahldialog an, in dem Sie Farben auswählen können.

 

Im Menü „Optionen“ gibt es eine neue Option zum Festlegen der Caret-Farbe für die Tab-Bearbeitungsfenster.

 

Im Menü „Optionen“ gibt es ein neues Untermenü zur Auswahl der Position der Fensterregisterkarte (oben, unten, links oder rechts).

 

Das Kontextmenü auf den Registerkartenbezeichnungen verfügt über einen neuen Eintrag „Vollständigen Pfad kopieren“, der den vollständigen Pfadnamen der Datei in dieser Registerkarte in die Zwischenablage kopiert.

 

Das Kontextmenü auf den Tab-Beschriftungen verfügt über einen neuen Eintrag „Alle schließen“, der alle Tab-Fenster schließt.

 

Der Menüeintrag „Registerkarten…“ wurde von „Optionen“ in „Bearbeiten“ verschoben.

 

Der Tooltip für den Transparenz-Schieberegler (untere rechte Ecke) zeigt jetzt die aktuelle Transparenzeinstellung an (20 – 255; höhere Werte sind undurchsichtiger).

 

Wenn Sie Text in ein Bearbeitungsfenster ziehen, wird das Fenster jetzt automatisch gescrollt, wenn Sie die Ränder erreichen.

 

Der Unicode-Wert in der Statusleiste für das Zeichen an der Cursorposition unterstützt jetzt UTF8-Multibyte-Zeichen.

 

 

Plugins:

 

Unterstützung für VS 2019 hinzugefügt.

 

Unterstützung für CD_Enter und CD_Leave hinzugefügt (siehe oben). Wenn Sie Verzeichnisse über die Befehlszeile ändern, TCC wird zunächst nach Aliasnamen dieser Namen suchen; Wenn keine Übereinstimmung gefunden wird, sucht es in den Plugins nach einem passenden Namen.

 

 

Hilfe:

 

Die Hilfe wurde mit einer neuen Version (8.0) von Hilfe und Handbuch erstellt.

 

 

Neue TMCD.INI-Anweisungen:

 

Diese Anweisungen werden im OPTION-Befehl in den Dialogen „Start“ und „Befehlszeile“ festgelegt:

 

AliasGlobalSize

 

AliasLocalSize

 

DirHistoryLocalSize

 

DirHistoryGlobalSize

 

FunctionGlobalSize

 

FunctionLocalSize

 

GlobalAliases

 

GlobalDirHistory

 

Globale Funktionen

 

Weltgeschichte

 

HistoryGlobalSize

 

HistoryLocalSize

 

 

Neue interne Variablen:

 

_osbuildex – Gibt die Windows-Build-Nummer + die Sub-Build-Nummer zurück (z. B. „19041.84“).

 

 

Neue Variablenfunktionen:

 

@DATEFMT - Formatiert ein Datum/eine Uhrzeit in einem benutzerdefinierten Format. Die Syntax lautet:

 

@DATEFMT[Datumsformat]

 

Datum – Das zu formatierende Datum (im Format jjjj-mm-tt hh:mm:ss). Wenn Datum ist *, @DATEFMT verwendet standardmäßig das aktuelle Datum/die aktuelle Uhrzeit. Gültige Daten sind 1. Januar 1970 (1970-1-1) bis 31. Dezember 3000 (3000-12-31). Die Uhrzeit muss im 24-Stunden-Format vorliegen.

 

Format – Das zu verwendende benutzerdefinierte Format. (Beachten Sie, dass die % normalerweise verdoppelt oder maskiert werden müssen, um dies zu verhindern TCC verhindern, dass sie erweitert werden, bevor @DATEFMT sie sieht.) Die Formatierungsoptionen sind:

 

Code

Ersatzsaite

%a

Abgekürzter Wochentagsname im Gebietsschema

%A

Vollständiger Wochentagsname im Gebietsschema

%b

Abgekürzter Monatsname im Gebietsschema

%B

Vollständiger Monatsname im Gebietsschema

%c

Darstellung von Datum und Uhrzeit im Gebietsschema

%C

Das Jahr dividiert durch 100 und gekürzt auf eine ganze Zahl als Dezimalzahl (00–99).

%d

Tag des Monats als Dezimalzahl (01 - 31)

%D

Gleichwertig %m/%d/%y

%e

Tag des Monats als Dezimalzahl (1 - 31), wobei einzelnen Ziffern ein Leerzeichen vorangestellt wird

%F

Gleichwertig %Y-%m-%d

%g

Die letzten beiden Ziffern des ISO 2-Wochenjahres (8601–00)

%G

Das ISO 8601-Wochenjahr als Dezimalzahl

%h

Abgekürzter Monatsname (entspricht %b)

%H

Stunde im 24-Stunden-Format (00 - 23)

%I

Stunde im 12-Stunden-Format (01 - 12)

%j

Tag des Jahres als Dezimalzahl (001 - 366)

%m

Monat als Dezimalzahl (01 - 12)

%M

Minute als Dezimalzahl (00 - 59)

%n

Ein Newline-Zeichen (\n)

%p

Die Vormittags-/Nachmittagszeit des Gebietsschemas Anzeige für 12-Stunden-Uhr

%r

Die 12-Stunden-Uhrzeit des Gebietsschemas

%R

Gleichwertig %HM

%S

Sekunde als Dezimalzahl (00 - 59)

%t

Ein horizontales Tabulatorzeichen (\t)

%T

Gleichwertig %H:%M:%S, das ISO 8601-Zeitformat

%u

ISO 8601-Wochentag als Dezimalzahl (1 - 7; Montag ist 1)

%U

Wochennummer des Jahres als Dezimalzahl (00 - 53), wobei der erste Sonntag der erste Tag der Woche 1 ist

%V

ISO 8601-Wochennummer als Dezimalzahl (00 - 53)

%w

Wochentag als Dezimalzahl (0 - 6; Sonntag ist 0)

%W

Wochennummer des Jahres als Dezimalzahl (00 - 53), wobei der erste Montag der erste Tag der Woche 1 ist

%x

Datumsdarstellung für das Gebietsschema

%X

Zeitdarstellung für das Gebietsschema

%y

Jahr ohne Jahrhundert, als Dezimalzahl (00 - 99)

%Y

Jahr mit Jahrhundert als Dezimalzahl

%z

Der Offset von UTC im ISO 8601-Format; keine Zeichen, wenn die Zeitzone unbekannt ist

%Z

Entweder der Zeitzonenname oder die Zeitzonenabkürzung des Gebietsschemas, abhängig von den Registrierungseinstellungen; keine Zeichen, wenn die Zeitzone unbekannt ist

%%

Prozentzeichen

 

Zeichen, die nicht mit einem % beginnen, werden unverändert angezeigt.

 

Der Cavalon Sentinel ist das AutoGyro-Premiummodell mit nebeneinander angeordneten Sitzen, verfügbar mit dem neuen hochmodernen und kraftstoffsparenden Rotax XNUMX iS-Motor. # Flag kann jedem Formatierungscode vorangestellt werden. In diesem Fall ändert sich die Bedeutung des Formatcodes wie folgt:

 

Code formatieren

Bedeutung

%#A, %#A, %#B, %#B, %#G, %#G, %#H, %#N, %#P, %#T, %#u, %#w, %#X, %#z, %#Z, %#%

# Flag wird ignoriert.

%#C

Lange Datums- und Uhrzeitdarstellung, passend zum Gebietsschema. Zum Beispiel: „Mittwoch, 25. März 2020, 12:41:29“.

%#X

Lange Datumsdarstellung, passend zum Gebietsschema. Zum Beispiel: „Mittwoch, 25. März 2020“.

%#D, %#D, %#e, %#F, %#H, %#ICH, %#J, %#M, %#M, %#R, %#R, %#S, %#T, %#U, %#V, %#W, %#y, %#Y

Entfernen Sie führende Nullen oder Leerzeichen (falls vorhanden).

 

Die ISO 8601-Woche und das wochenbasierte Jahr, erstellt von %V, %g und %Gverwendet eine Woche, die am Montag beginnt, wobei Woche 1 die Woche ist, die den 4. Januar enthält, also die erste Woche, die mindestens vier Tage im Jahr umfasst. Wenn der erste Montag des Jahres der 2., 3. oder 4. ist, gehören die vorhergehenden Tage zur letzten Woche des vorangegangenen Jahres. Für jene Tage, %V wird durch 53 ersetzt, und beides %g und %G werden durch die Ziffern des Vorjahres ersetzt.

 

@DATEITYP - gibt den Kodierungstyp der Datei zurück. Die Syntax lautet:

 

@DATEITYP[Dateinamen]

 

Sie müssen die UTF8-Eingabe für aktivieren TCC um UTF8-Dateien zu erkennen; siehe OPTION / Setup. Die möglichen Rückgabewerte sind:

 

ASCII

Utfxnumx

Utfxnumx

 

 

Aktualisierte interne Variablen:

 

_DOS – Unterstützung für Windows Server 2019 hinzugefügt.

 

 

Aktualisierte Variablenfunktionen:

 

@CRC32 - Wenn das erste Argument „sa“ ist, behandeln Sie das zweite Argument als ASCII-Zeichenfolge. Wenn das erste Argument „s8“ ist, behandeln Sie das Argument als UTF8-Zeichenfolge.

 

@EVAL - hat ein optionales +-Argument am Ende der Präzisionszeichenfolge (d. h. %@eval[nnn=x.y+], um anzugeben, dass positiven Ergebnissen ein + vorangestellt werden soll.

 

@GESCHICHTE – verfügt über ein optionales drittes Argument, das angibt, ob Sie die lokale Verlaufsliste oder die globale Verlaufsliste wünschen. (Wenn Sie die zu verwendende Verlaufsliste, aber nicht das (optionale zweite Argument) zurückzugebende Wort angeben möchten, legen Sie fest Wort bis 1.)

 

@GESCHICHTE[Eintrag[, Wort, [L | G]]]

 

@LINIE - Unterstützung für UTF8-Dateien hinzugefügt.

 

@LINIEN - Unterstützung für UTF8-Dateien hinzugefügt.

 

@MD5- Wenn das erste Argument „sa“ ist, behandeln Sie das zweite Argument als ASCII-Zeichenfolge. Wenn das erste Argument „s8“ ist, behandeln Sie das Argument als UTF8-Zeichenfolge.

 

@SHA1- Wenn das erste Argument „sa“ ist, behandeln Sie das zweite Argument als ASCII-Zeichenfolge. Wenn das erste Argument „s8“ ist, behandeln Sie das Argument als UTF8-Zeichenfolge.

 

@SHA256- Wenn das erste Argument „sa“ ist, behandeln Sie das zweite Argument als ASCII-Zeichenfolge. Wenn das erste Argument „s8“ ist, behandeln Sie das Argument als UTF8-Zeichenfolge.

 

@SHA384- Wenn das erste Argument „sa“ ist, behandeln Sie das zweite Argument als ASCII-Zeichenfolge. Wenn das erste Argument „s8“ ist, behandeln Sie das Argument als UTF8-Zeichenfolge.

 

@SHA512- Wenn das erste Argument „sa“ ist, behandeln Sie das zweite Argument als ASCII-Zeichenfolge. Wenn das erste Argument „s8“ ist, behandeln Sie das Argument als UTF8-Zeichenfolge.

 

 

Aktualisierte Befehle:

 

ALIAS

 

ALIAS unterstützt jetzt sowohl lokale als auch globale Listen gleichzeitig. Wenn Sie sowohl lokale als auch globale Listen definiert haben, können Sie beim Anzeigen, Erstellen oder Löschen von Aliasen angeben, welche Liste ALIAS verwenden soll.

 

/GL – verwendet die globale Aliasliste

 

/LL – Verwenden Sie die lokale Aliasliste

 

Wenn Sie sowohl lokale als auch globale Listen definiert haben und /GL nicht angeben, verwendet ALIAS standardmäßig die lokale Liste.

 

TCC sucht zunächst nach Aliasen in der lokalen Liste; falls nicht gefunden TCC durchsucht die globale Liste.

 

Wenn Sie die Option /G verwenden, um eine lokale Aliasliste in eine globale Aliasliste zu konvertieren, führt ALIAS die Konvertierung nicht durch, wenn bereits eine globale Aliasliste vorhanden ist (z. B. in einer anderen). TCC Sitzung oder in SHRALIAS).

 

Zwei neue optionale Spezialaliase hinzugefügt CD_Enter und CD_Leave (siehe oben).

 

/R – Unterstützung für UTF8-Dateien hinzugefügt.

 

FARBE

 

Neue Optionen zum Festlegen der Vordergrund- und Hintergrundfarbe in a hinzugefügt TCC Konsolenfenster (kein TCMD-Registerkartenfenster) auf 16 Millionen oder 256 Farben. Sie müssen Windows 10 oder 11 ausführen und ANSI aktiviert haben.

 

/FG r,g,b - Setzt die Vordergrundfarbe auf den angegebenen RGB-Wert von 16 Millionen Farben. Gültige Bereiche für r, g und b sind 0–255.

 

/BG r,g,b - Setzt die Hintergrundfarbe auf den angegebenen RGB-Wert von 16 Millionen Farben. Gültige Bereiche für r, g und b sind 0–255.

 

/FG Farbe - Setzt die Vordergrundfarbe auf den angegebenen 256-Farben-Wert (xterm). Gültiger Bereich für Farbe ist 0 - 255.

 

/BG Farbe - Setzt die Hintergrundfarbe auf den angegebenen 256-Farben-Wert (xterm). Gültiger Bereich für Farbe ist 0 - 255.

 

/P [Farbe] – Zeigt einen Farbauswahldialog zur Auswahl einer Farbe an. Muss mit /FG oder /BG verwendet werden und kann nicht mit /F kombiniert werden.

 

COPY

 

COPY /S zeigt nun die Anzahl der kopierten Verzeichnisse an (falls vorhanden).

 

/CDA – Kopieren Sie die Attribute aus jedem der Quellunterverzeichnisse in die Zielunterverzeichnisse.

 

DATUM

 

DATE hat eine neue Option „datefmt", das das aktuelle Datum/die aktuelle Uhrzeit in einem benutzerdefinierten Format anzeigt. Die Formatierungszeichen sind dieselben wie die, die von der Funktion @DATEFMT verwendet werden (siehe oben). Die DATE-Syntax lautet:

 

DATUM [/Fn /T /U "Format"] [MM-TT-JJ]] [AM | PN]

 

DEL

 

DEL /S /X zeigt nun die Anzahl der entfernten Verzeichnisse an (falls vorhanden).

 

DELAY

 

DELAY hh:mm:ss oder DELAY mm:ss wartet die angegebene Zeitspanne.

 

BESCHREIBEN

 

DESCRIBE unterstützt jetzt UTF8-Beschreibungsdateien.

 

DIR

 

/CD:"Farbdir„ – Definieren Sie eine benutzerdefinierte Verzeichnisfarbzeichenfolge, die anstelle der Umgebungsvariablen COLORDIR oder der Option ColorDir in TCMD.INI verwendet werden soll.

 

VERZEICHNIS

 

DIRHISTORY unterstützt jetzt sowohl lokale als auch globale Listen gleichzeitig. Beim Anzeigen, Erstellen oder Löschen von Einträgen im Verzeichnisverlauf können Sie angeben, welche Liste DIRHISTORY durchsuchen soll:

 

/GL – verwendet die globale Verzeichnisverlaufsliste

 

/LL – Verwenden Sie die Verlaufsliste des lokalen Verzeichnisses

 

Beim Durchsuchen des Verzeichnisverlaufs TCC sucht zuerst in der lokalen Liste (sofern vorhanden) und dann in der globalen Liste (sofern vorhanden).

 

Wenn Sie die Option /G verwenden, um eine lokale Verzeichnis-Verlaufsliste in eine globale Verzeichnis-Verlaufsliste zu konvertieren, führt DIRHISTORY die Konvertierung nicht durch, wenn bereits eine globale Verzeichnis-Verlaufsliste vorhanden ist (z. B. in einer anderen). TCC Sitzung oder in SHRALIAS).

 

DO

 

DO löscht alle temporären Dateien, die mit CLIP: in einer DO-Anweisung erstellt wurden.

 

ENDLOCAL

 

Wenn Sie nur globale Aliase definiert haben, stellt ENDLOCAL die von SETLOCAL gespeicherte globale Liste wieder her (wie in früheren Versionen). Wenn Sie sowohl lokale als auch globale Aliase definiert haben, stellt ENDLOCAL nur die lokale Liste wieder her, die von SETLOCAL gespeichert wurde. Siehe auch SETLOCAL.

 

ESET

 

/LL (oder /LL) – Verwenden Sie den globalen Alias ​​oder die Funktionsliste. ESET verwendet standardmäßig die lokale Liste, sofern diese vorhanden ist. Ist dies nicht der Fall, sucht ESET nach einer globalen Liste.

 

/G (oder /GL) – verwenden Sie den lokalen Alias ​​oder die Funktionsliste.

 

ALLES

 

Everything Search wurde auf Version 1.4.1.969 aktualisiert.

 

Der Cavalon Sentinel ist das AutoGyro-Premiummodell mit nebeneinander angeordneten Sitzen, verfügbar mit dem neuen hochmodernen und kraftstoffsparenden Rotax XNUMX iS-Motor. TCC / Everything Search-Integration ist schneller und verbraucht weniger Speicher.

 

AUSSER

 

/NM – Wenn für die Argumente in der Ausnahmeliste keine Übereinstimmung gefunden wird, führt EXCEPT den Befehl nicht aus.

 

FINDEN

 

/TE"Text" - Konvertiert eine Textzeichenfolge in einen regulären Ausdruck und führt dann eine Regex-Suche durch. Sie müssen reguläre Ausdrücke nicht erlernena,d und /TE wird 10x schneller ausgeführt als /T. Die einzige Einschränkung ist die maximale Zeilenlänge in der Datei muss < 16 MB sein.

 

AUFGABE

 

FUNCTION unterstützt jetzt sowohl lokale als auch globale Listen gleichzeitig. Wenn Sie sowohl lokale als auch globale Listen definiert haben, können Sie beim Anzeigen, Erstellen oder Löschen von Funktionen angeben, welche Liste FUNCTION verwenden soll.

 

/GL – globale Funktionsliste verwenden

 

/LL – Verwenden Sie die lokale Funktionsliste

 

Wenn Sie sowohl lokale als auch globale Listen definiert haben und /GL nicht angeben, verwendet FUNCTION standardmäßig die lokale Liste.

 

TCC sucht zunächst in der lokalen Liste nach einer benutzerdefinierten Funktion; falls nicht gefunden TCC durchsucht die globale Liste.

 

Wenn Sie die Option /G verwenden, um eine lokale Funktionsliste in eine globale Funktionsliste zu konvertieren, führt FUNCTION die Konvertierung nicht durch, wenn bereits eine globale Funktionsliste vorhanden ist (z. B. in einer anderen). TCC Sitzung oder in SHRALIAS).

 

/R – Unterstützung für UTF8-Dateien hinzugefügt.

 

GESCHICHTE

 

HISTORY unterstützt jetzt sowohl lokale als auch globale Listen gleichzeitig. Beim Anzeigen, Erstellen oder Löschen von Verlaufseinträgen können Sie festlegen, welche Liste mit HISTORY durchsucht werden soll:

 

/GL – verwendet die globale Verlaufsliste

 

/LL – Verwenden Sie die lokale Verlaufsliste

 

Beim Durchsuchen des Verlaufs TCC sucht zuerst in der lokalen Liste (sofern vorhanden) und dann in der globalen Liste (sofern vorhanden).

 

Wenn Sie die Option /G verwenden, um eine lokale Verlaufsliste in eine globale Verlaufsliste zu konvertieren, führt HISTORY die Konvertierung nicht durch, wenn bereits eine globale Verlaufsliste vorhanden ist (z. B. in einer anderen). TCC Sitzung oder in SHRALIAS).

 

/R – Unterstützung für UTF8-Dateien hinzugefügt.

 

BIBLIOTHEK

 

Unterstützung für UTF8-Bibliotheksdateien hinzugefügt.

 

LISTE

 

LIST unterstützt jetzt das Rückwärtsblättern durch weitergeleitete Eingaben.

 

SPEICHER

 

MEMORY zeigt jetzt die lokalen und globalen Alias- und Funktionsgrößen an.

 

MOVE

 

MOVE /S zeigt nun die Anzahl der verschobenen Verzeichnisse an (falls vorhanden).

 

/MDA – Kopieren Sie die Attribute aus jedem der Quellunterverzeichnisse in die Zielunterverzeichnisse. (Nur gültig, wenn auf ein anderes Laufwerk verschoben wird. Andernfalls führt MOVE eine Umbenennung des Verzeichnisses der obersten Ebene durch und alle Attribute des Unterverzeichnisses bleiben erhalten.)

 

MSGBOX

 

If TCC läuft in a Take Command Im Tab-Fenster wird das Meldungsfeld zentriert im Tab-Fenster angezeigt.

 

/PC – zentriert das Meldungsfeld auf dem Desktop.

 

/X – das Meldungsfeld kann nicht verschoben werden.

 

zur Auswahl

 

Es gibt neue Optionen zum Festlegen globaler und/oder lokaler Aliase, benutzerdefinierter Funktionen, des Befehlsverlaufs und des Verzeichnisverlaufs.

 

Es gibt neue Optionen zum Festlegen der globalen und/oder lokalen Größen für Aliase, benutzerdefinierte Funktionen, Befehlsverlauf und Verzeichnisverlauf.

 

PDIR

 

/CD:"Farbdir„ – Definieren Sie eine benutzerdefinierte Verzeichnisfarbzeichenfolge, die anstelle der Umgebungsvariablen COLORDIR oder der Option ColorDir in TCMD.INI verwendet werden soll.

 

PROMPT

 

$: – Zeigt den Prompt-Timer im Format hh:mm:ss.ms an.

 

$„datefmt" – Zeigt das aktuelle Datum/die aktuelle Uhrzeit in einem benutzerdefinierten Format an. Die Formatierungszeichen sind dieselben wie die, die von der Funktion @DATEFMT verwendet werden (siehe oben).

 

QUERYBOX

 

Die maximale Längenbeschränkung (vorher 255 Zeichen) für die Eingabezeichenfolge wurde entfernt.

 

Die maximale Längenbeschränkung (bisher 127 Zeichen) für die /CUE-Zeichenfolge wurde entfernt.

 

REGDIR

 

/Nb – Zeigt den Inhalt von REG_BINARY-Werten nicht an.

 

/TS – Sekunden in die Anzeige der letzten Schreibzeit einbeziehen.

 

REGDIR zeigt nun alle Zeichenfolgen in einem REG_MULTI_SZ an.

 

REN

 

REN /S zeigt nun die Anzahl der umbenannten Verzeichnisse an.

 

SETLOCAL

 

Wenn Sie nur globale Aliase definiert haben, verhält sich SETLOCAL wie in früheren Versionen und kopiert vorübergehend die globale Liste in eine lokale Liste und stellt die globale Liste auf einem ENDLOCAL wieder her. Wenn Sie sowohl lokale als auch globale Aliase definiert haben, speichert SETLOCAL nur die lokale Liste, die von ENDLOCAL wiederhergestellt wird.

 

SETARRAY

 

/R unterstützt jetzt UTF8-Dateien.

 

SHORTCUT

 

SHORTCUT versucht nicht, den Befehl, das Startverzeichnis oder den Linkdateinamen vollständig zu qualifizieren, wenn sie %s enthalten. Dadurch können Sie Variablen in die Argumente einbetten, die von Windows erweitert werden.

 

TEE

 

/F„datefmt„ – Stellen Sie jeder Zeile einen Zeitstempel in einem benutzerdefinierten Format voran. Die Formatierungszeichen sind die gleichen, die auch von verwendet werden @DATEFMT Funktion (siehe oben).

 

ZEIT-

 

TIME hat eine neue Option „datefmt", das das aktuelle Datum/die aktuelle Uhrzeit in einem benutzerdefinierten Format anzeigt. Die Formatierungszeichen sind dieselben wie die, die von verwendet werden @DATEFMT Funktion (siehe oben). Die TIME-Syntax lautet:

 

ZEIT [/S [Server] /T /U "Format"] [hh[:mm:ss]]] [AM | PN]

 

TPIPE

 

Die TextPipe Engine-Version wurde von 9.9.4 auf 11.6 aktualisiert.

 

Die TextPipeEngine-DLL ist jetzt 64-Bit (für die x64-Version von TCC). (Der anfängliche Ladevorgang ist etwas langsamer, aber alles läuft schneller.)

 

Aktualisierte Unicode-Kompositions-/Zerlegungsfunktionen für NFC, NFD, NFKC, NFKD.

 

Aktualisierte PDF-Bibliotheken.

 

Aktualisierte Codepage-konvertierte Bibliothek.

 

Aktualisierte Bibliothek für reguläre Ausdrücke.

 

Die Unicode-Unterstützung wurde auf Unicode 12.1 aktualisiert.

 

Neue Option zum Hinzufügen von Zeilennummern (zum Zurücksetzen am Anfang einer neuen Datei).

 

Der Zeilennummernfilter verfügt über eine neue Option:

 

/line=StartNumber,Increment,SkipBlank,DontNumberBlank,NumberFormat[,DontReset[,ResetNewFile]]

 

ResetNewFile - Wenn 1, wird der Zähler am Anfang einer neuen Datei zurückgesetzt. Der Standardwert ist 0.

 

Neuer Auswahlfilter hinzugefügt:

 

/selection2=Typ, ColumnSpec, MoveTo, ProcessIndividuell, ExcludeDelimiter, ExcludeQuotes, Delimiter, CustomDelimiter, HasHeader

Typ – der Typ des hinzuzufügenden Filters

0 Spalte löschen

1 Leitungen einschränken

2 Spalten einschränken

3 Auf Bytes beschränken

4 Auf durch Trennzeichen getrennte Felder beschränken (CSV, Tab, Pipe usw.)

5 - unbenutzt

6 Leitungen entfernen

7 Durch Trennzeichen getrennte Felder entfernen (CSV, Tab, Pipe usw.)

9 Spalten verschieben

10 Durch Trennzeichen getrennte Felder verschieben (CSV, Tab, Pipe usw.)

12 Spalten kopieren

13 Durch Trennzeichen getrennte Felder kopieren (CSV, Tab, Pipe usw.)

17 Bytebereich entfernen

18 Felder extrahieren

ColumnSpec – die in doppelte Anführungszeichen gesetzte Liste der zu entfernenden Elemente, z. B. „1..10, 16, 20“

moveTo: Ganzzahl – wohin die Spalten oder Felder verschoben oder kopiert werden sollen. Standard 1.

ProcessIndividuell – ob Unterfilter auf jedes CSV- oder Tab-Feld einzeln oder auf die Felder als ein Zeichenfolgenwert angewendet werden sollen oder nicht. Standardmäßig falsch.

excludeDelimiter – legt fest, ob bei der Übergabe des Felds an den Unterfilter das Feldtrennzeichen Komma oder Tab eingefügt werden soll oder nicht. Standardmäßig wahr.

excludeQuotes – ob die CSV-Anführungszeichen, die das Feld umgeben können, bei der Übergabe des Feldes an den Unterfilter einbezogen werden sollen oder nicht. Standardmäßig wahr.

Trennzeichen – (optional) der Index des zu verwendenden Standardtrennzeichens oder 6 für benutzerdefiniert, Standard 0 für CSV

customDelimiter – (optional) das zu verwendende benutzerdefinierte Trennzeichen in doppelten Anführungszeichen, standardmäßig leer

hasHeader – (optional) true, wenn die erste Zeile der Datei eine Kopfzeile ist, standardmäßig false.

 

Der End-of-Line-Filter verfügt über zwei neue Optionen:

 

/eol=Eingabe,Ausgabe,Länge,LFString,Entfernen

 

LFString – die neue Zeilenvorschubzeichenfolge bei der Ausgabe, wenn Option 4 für Eingabe ausgewählt wird

Entfernen – ob fehlerhafte EOLs entfernt werden sollen (Standard 1)

 

Spaltenspezifikationen für das Löschen, Extrahieren und Einschränken von durch Trennzeichen getrennten Feldern können jetzt mehrere Spalten in einem Filter angeben, z. B. 6, 9, 61..63.

 

JSON-Ausgabeformat zum Datenbankfilter hinzugefügt.

 

/database=Modus,...

 

Modus = 4 – JSON

 

Die Filter „Tab in JSON konvertieren“ und „JSON in Tab konvertieren“ wurden hinzugefügt.

 

/simple=Typ

 

type = 86 – JSON in Tab konvertieren

type = 87 – Tab in JSON konvertieren

 

Filter „Word-Dokumente in RTF konvertieren“ hinzugefügt.

 

/Simple=Typ

 

type = 88 – Word-Dokumente in RTF konvertieren

 

Neue Sortierung nach UTF-8 (Groß- und Kleinschreibung beachten).

 

/sort=Typ,...

 

Typ = 9 – UTF8-Sortierung (ohne Berücksichtigung der Groß-/Kleinschreibung)

Typ = 10 – UTF8-Sortierung (Groß-/Kleinschreibung beachten)

 

/InputClipboardUnicode=[0|1] – Steuert im Zwischenablagemodus, ob die Eingabe als ANSI oder Unicode behandelt wird. Der Standardwert ist 0 (ANSI).

 

Dem /Split=-Filter wurden Optionen hinzugefügt:

 

/split=type,SplitSize,SplitChar,SplitCharPos,SplitCharCount,SplitLines,SplitFilename[,FirstFileNumber[,PreventOverload]]

 

FirstFileNumber – (optional) die Nummer der ersten Datei, Standard 0

PreventOverload – (optional) „true“, um mehr als 10,000 Dateien in einem Ordner zu verhindern, standardmäßig „false“.

 

Beim Laden/Speichern von Dateien wird standardmäßig UTF8-Kodierung anstelle von ANSI verwendet.

 

Verbesserter Perl-Regex-Filter, um Unicode-Zeichen zum Trennen ganzer Wörter zu ermöglichen.

 

Filter zur Änderung der Groß-/Kleinschreibung wurden aktualisiert, um mit UTF-8-codiertem Text zu funktionieren.

 

Die Filter „Word/Excel/PDF in Text konvertieren“ wurden geändert, um UTF-8-Text auszugeben.

 

Der Filter „Stückliste entfernen“ erkennt jetzt, ob die Datei geändert wurde oder nicht, und verarbeitet UTF-16 LE ordnungsgemäß.

 

Such-/Ersetzungslistenfilter unterstützen jetzt Unicode.

 

Verbesserter Zeilennummerierungsfilter, um den Unterschied zwischen Dateianfang und Einschränkungsanfang korrekt zu erkennen.

 

Verbesserte Fehlerbehandlung für Spezifikationsfilter, die nicht mehrere Bereiche unterstützen.

 

Verbesserte Fehlerbehandlung für Skriptfilter und Ladeeinstellungen und Sprachen.

 

Feldspezifikationsfilter unterstützen jetzt Feldnamen mit eingebetteten Bindestrichen (-), und Feldnamen mit Leerzeichen können verwendet werden, indem sie in Anführungszeichen gesetzt werden.

 

Es wird nun eine Warnung ausgegeben, wenn eine Feldspezifikation nicht mit den in einer Datei gefundenen Feldnamen übereinstimmt.

 

Die Geschwindigkeit des Suchens/Ersetzens nach „genauer Übereinstimmung“ wurde verbessert.

 

Die Text-zu-Wort-Liste erkennt jetzt englische Possessive (oder andere Abkürzungen), die mit „s“ enden.

 

„Leerzeichen vom Zeilenanfang/Zeilenende entfernen“ wurde aktualisiert, um UTF-8 e3 80 80 IDEOGRAPHIC SPACE zu verarbeiten (im chinesischen Text üblich).

 

Filter für geteilte Dateien entfernen jetzt die letzte Datei, wenn sie null Bytes hat.

 

Der Split-Filter verarbeitet Makros jetzt, nachdem die Dateinummerierung erfolgt ist.

 

Datenbankfilter ändern jetzt die Ausgabeerweiterung, um sie an das Format anzupassen.

 

Der Filter „URL extrahieren“ kommt jetzt mit jedem Schema zurecht, von den zuvor unterstützten mailto:, http:, https:, nntp:, gopher:, ftp:, ftps: bis hin zu neueren wie call: und skype:

 

Verbesserte Protokollausgabe, um Informationen für jeden Filtertyp bereitzustellen (sehr nützlich für das Filter-Debugging).

 

TPIPE sucht jetzt nach „Zombie“-Filtern, die dem sekundären Ausgabefilter eines T-Filters folgen (diese Filter bewirken nichts).

 

Neuer Filter zum Konvertieren von Word-Dokumenten in RTF.

 

Bei HTML-Entitäten wird jetzt die Groß-/Kleinschreibung beachtet.

 

Das Protokoll enthält jetzt Filtersymbole zur leichteren Identifizierung.

 

Bei der Konvertierung von CSV in Tab entfallen jetzt unnötige Anführungszeichen.

 

OpenOffice-Unterstützung für ODT, ODS und ODP.

 

TREE

 

Unterstützung für die Einfärbung der Ausgabe von TREE hinzugefügt. Die Farboptionen und das Format sind die gleichen wie bei DIR und können Folgendes umfassen:

 

Erweiterung

Dateiattribut

Dateigröße

Datum/Uhrzeit der Datei

Ausführbarer Typ

Ranges

 

VER

 

/C – zeigt die Versionsinformationen im gleichen Format wie CMD an (d. h. „Microsoft Windows [Version 10.0.19559.1000]“).

 

ANZEIGEN

 

/W – Wenn in a Take Command Tab-Fenster, verschiebt das VIEW-Fenster in das Tab-Fenster (und behält es dort, wenn Sie die Größe ändern oder verschieben). Take Command Fenster). Wenn in einem TCC Konsolenfenster, passt die Größe des VIEW-Fensters an und verschiebt es auf die gleiche Größe und Position wie das TCC Fenster (aber Sie können das VIEW-Fenster wegziehen).

 

Das Menü Bearbeiten bietet neue Optionen zum Kopieren in die Zwischenablage:

 

Aktuelle Zeile kopieren (Strg+Y)

 

CSV-Kopieren der aktuellen Zeile

 

Umschalt+Klick auf den CSV-Spaltenkopf, um die gesamte Spalte auszuwählen.

 

Y

 

Es gibt drei neue Optionen zum Zeitstempeln der STDIN-Zeilen, die Y nach STDOUT schreibt:

 

/D – Stellen Sie jeder Zeile das aktuelle Datum voran (im Format JJJJ-MM-TT).

 

/F"Format" – eine benutzerdefinierte Uhrzeit/ein benutzerdefiniertes Datum Format Zeichenfolge. Sehen @DATEFMT (oben) für Einzelheiten dazu Format Argumente.

 

/T – Stellen Sie jeder Zeile die aktuelle Uhrzeit voran (im Format hh:mm:ss.ms).

 

WMIQUERY

 

/Q – verhindert die Anzeige des Eigenschaftsnamens beim Anzeigen von Eigenschaften.

 

 

Neue Befehle:

 

CHRONISCH

 

CHRONIC führt einen Befehl aus und verbirgt seine STDOUT- und STDERR-Ausgabe, es sei denn, der Befehl schlägt fehl (Rückgabewert != 0). Wenn der Befehl erfolgreich ist, wird keine Ausgabe angezeigt. Die Syntax lautet:

 

CHRONISCH [/R] Befehl ...

 

/R – Zeigt die Ausgabe an, wenn der Befehl in STDERR schreibt. Wenn /R nicht angegeben ist, zeigt CHRONIC die Ausgabe nur an, wenn der Befehl einen Exit-Code ungleich Null zurückgibt.

 

CHRONIC zeigt die STDOUT- und STDERR-Ausgabe getrennt an. Zum Beispiel:

 

c:\> CHRONISCH Testbefehl

Exit-Code: 2

STDOUT:

stdout-Ausgabe hier ...

STDERR:

stderr-Ausgabe hier ...

 

PINKELN

 

PEE ähnelt TEE, leitet STDOUT jedoch nicht an mehrere Dateien, sondern über Pipes an mehrere sekundäre Befehle weiter. Die Syntax lautet:

 

PEE /= /D /F"Format" /R /T App ...

 

/= – Zeigt den PEE-Befehlsdialog an

 

/D – jeder Zeile das aktuelle Datum voranstellen

 

/F"Format" – eine benutzerdefinierte Uhrzeit/ein benutzerdefiniertes Datum Format Zeichenfolge. Sehen @DATEFMT (oben) für Einzelheiten dazu Format Argumente.

 

/R – STDERR auch umleiten

 

/T – stellt jeder Zeile die aktuelle Uhrzeit voran

 

SCHWAMM

 

SPONGE liest die Standardeingabe und schreibt sie in die angegebene Datei. Im Gegensatz zur Ausgabeumleitung liest SPONGE alle seine Eingaben, bevor die Ausgabedatei geöffnet wird. Dadurch können Pipes erstellt werden, die aus derselben Datei lesen und in dieselbe schreiben. SPONGE liest Standardeingaben in einen Speicherpuffer, daher wird die Weiterleitung extrem großer Datenmengen (d. h. mehrere Gigabyte) nicht empfohlen.

 

Die Syntax lautet:

 

SCHWAMM [/A] Name der Ausgabedatei

 

/A – Ausgabe anhängen Name der Ausgabedatei. Die Standardeinstellung ist Überschreiben Name der Ausgabedatei.

 

TS

 

TS liest Zeilen von STDIN, stellt einen Datums-/Zeitstempel voran und schreibt die Zeile nach STDOUT. TS soll in Pipes verwendet werden, wenn Sie wissen müssen, wann jede Zeile empfangen wurde. Die Syntax lautet:

 

TS [/D /T "Format"]

 

/D – Stellen Sie jeder Zeile das aktuelle Datum voran (im Format JJJJ-MM-TT).

 

/T – Stellen Sie jeder Zeile die aktuelle Uhrzeit voran (im Format hh:mm:ss.ms).

 

"..." - Der Format Zeichenfolge. Sehen @DATEFMT (oben) für Einzelheiten dazu Format Argumente.

 

Wenn Sie keine Optionen angeben, verwendet TS standardmäßig /D /T.