Was ist neu in Version 32?

Take Command 32.10:

 

 

IDE / Batch-Debugger:

 

Unterstützung für das Erstellen und Bearbeiten von NTFS-Streams hinzugefügt. Die Syntax ist „Dateiname.ext:Streamname".

 

 

TCEDIT:

 

Unterstützung für das Erstellen und Bearbeiten von NTFS-Streams hinzugefügt. Die Syntax ist „Dateiname.ext:Streamname".

 

 

Neue interne Variablen:

 

_BATCHLABEL - Gibt den Namen der aktuellen GOSUB-Unterroutine zurück. (Oder eine leere Zeichenfolge, wenn nicht in einer Unterroutine.)

 

 

Neue Variablenfunktionen:

 

@XHISTORY - Gibt die passende XHISTORY-Zeile oder das entsprechende XHISTORY-Feld zurück. Die Syntax lautet:

 

@XHISTORY[Linie, arg] Wo:

 

Linie – die Nummer der zurückzugebenden Zeile. Der jüngste XHISTORY-Eintrag ist Zeile 0, der vorherige Eintrag 1 usw.

 

arg - das zurückzugebende XHISTORY-Argument:

 

0 – Zeitstempel

1 - Ausführungszeit

2 – Rückgabecode

3 - CWD

4 - Befehl

 

 

Aktualisierte Befehle:

 

COPY

 

/G – schreibt jetzt den Fortschritt % direkt auf die Anzeige statt auf STDOUT.

 

DO / ITERIEREN

 

ITERIEREN n - wenn n angegeben ist und > 0, wird ITERATE beendet n verschachtelte DO-Schleifen und iterieren Sie dann die nDie übergeordnete DO-Schleife.

 

MOVE

 

/G – Schreibt jetzt den Fortschritt % direkt auf die Anzeige statt auf STDOUT.

 

Popd

 

/N – Das Verzeichnis vom Stapel entfernen, aber das Verzeichnis nicht ändern.

 

Pushd

 

/N – Verschieben Sie das Verzeichnis auf den Stapel, ändern Sie das Verzeichnis jedoch nicht.

 

RD

 

/Nj – Keinen Junctions/Symlinks folgen

 

UHR

 

Der WATCH-Header zeigt jetzt einen Zeitstempel vor dem Befehlsnamen an.

 

/A – Hebt alle Änderungen zwischen dem aktuellen Lauf und dem ersten hervor, anstelle der Differenz zwischen dem aktuellen und dem vorherigen Lauf.

 

/B – Piept, wenn der Rückkehrcode != 0 ist

 

/F – Friert die Anzeige ein, wenn sich die Ausgabe geändert hat, und fordert Sie auf, einen Schlüssel einzugeben, um fortzufahren.

.

/U – Piepton, wenn sich die Ausgabe ändert

 

/X – Wird beendet, wenn sich die Ausgabe ändert

 

 

Neue Befehle:

 

ANRUFER

 

Gibt den Kontext des aktuellen Batch-Aufrufs zurück, einschließlich der Zeilennummer, der (optionalen) Unterprogrammbezeichnung und des Batch-Datei- oder Bibliotheksnamens. Die Syntax lautet:

 

ANRUFER n

 

If n nicht angegeben ist, zeigt CALLER die Zeilennummer und den Batchdatei- oder Bibliotheksnamen für die aktuelle Zeile an. Wenn n angegeben ist, zeigt CALLER die Zeilennummer, die Bezeichnung des Unterprogramms (oder „main“, wenn es sich nicht um ein Unterprogramm handelt) und den Batch- oder Bibliotheksnamen an. Der n Wert für die aktuelle Zeile ist 0, der vorherige Aufruf im Programmstapel ist 1 usw.

 

EXEC

 

Ersetzen Sie den Strom TCC Shell mit dem angegebenen Programm. Die Syntax lautet:

 

EXEC Befehl [Argumente ...]

 

FALSCH

 

Gibt 0 zurück (und setzt ERRORLEVEL auf 0).

 

FSEARCH

 

Durchsuchen Sie Dateien nach Text. (FSEARCH ist der Ersatz für das veraltete und bald veraltete FFIND, und die Optionen und die Syntax sind nahezu identisch. Neue Funktionen werden nur in FSEARCH implementiert, nicht in FFIND. (FSEARCH ist völlig neuer Code; das ist nicht der Fall Teilen Sie alles mit FFIND.) Die FSEARCH-Syntax lautet:

 

FSEARCH [/= /+n /-n /8 /B /C /E"Regex" /F /G /H /I /L /N[dehjs] /Q /S[[+]n] /T"Text" /U /V /Y /Z] [Weg] Dateinamen

 

/= – Zeigt das FSEARCH-Dialogfeld an

 

/+n - Überspringen Sie den ersten n Streichhölzer

 

/-n - Stopp nach n Streichhölzer

 

/8 – Anstatt die Dateien nach ihrem Typ zu durchsuchen, wird davon ausgegangen, dass sie UTF8 sind (das ist etwas schneller).

 

/B – Nur Dateinamen anzeigen (keine Kopf- oder Fußzeile oder Zusammenfassung oder übereinstimmende Zeilen)

 

/C – Groß-/Kleinschreibung anpassen

 

/E"..." – Suche nach regulären Ausdrücken

 

/F – Stopp nach dem ersten Treffer (überschreibt /V)

 

/G – Wechseln Sie in das Verzeichnis, das die erste passende Datei enthält (setzt außerdem /F und überschreibt /V)

 

/H – In Binärdateien nicht nach Text suchen. Standardmäßig umfasst dies .exe, .dll, .sys, .chm, .zip, .pdb, .pch, .obj,

.tar, .com und .ewriter. Sie können Ihre eigene Liste definieren, indem Sie die Umgebungsvariable „BINARY_FILES“ festlegen.

 

So ignorieren Sie beispielsweise .exe-, .sys- und .dll-Dateien:

 

BINARY_FILES=.exe;.sys;.dll

 

/I – Wird mit /T verwendet, um FSEARCH anzuweisen, Platzhalterzeichen (*, ? und [...]) zu ignorieren.

 

/L – Zeilennummern für übereinstimmenden Text anzeigen

 

/N... – Optionen deaktivieren:

 

D – Versteckte Unterverzeichnisse nicht scannen

 

E – Fehler nicht anzeigen

 

H – Kein Header

 

J – Kreuzungen überspringen

 

S – Keine Fußzeile (Zusammenfassung)

 

/Q – Keine Ausgabe anzeigen. Die internen Variablen (siehe unten – _fsearch_errors, _fsearch_files und _fsearch_matches sind einstellen).

 

/S – Unterverzeichnisse des angegebenen (oder Standard-)Pfads durchsuchen.

 

Wenn Sie nach dem /S eine Zahl angeben, begrenzt FFIND die Unterverzeichnisrekursion auf die angegebene Zahl. Wenn Sie beispielsweise einen Verzeichnisbaum „\a\b\c\d\e“ haben, wechselt /S2 nur zu den Verzeichnissen „a“, „b“ und „c“.

Wenn Sie nach dem /S ein + gefolgt von einer Zahl angeben, sucht FFIND erst nach Dateien, wenn diese Tiefe im Unterverzeichnisbaum erreicht ist. Wenn Sie beispielsweise einen Verzeichnisbaum \a\b\c\d\e haben, findet /S+2 nichts in \a oder \a\b.

 

/T"..." – Suche nach dem passenden Text. Unterstützt TCC Platzhalter (?, * und [...]).

 

/U – Nur Zusammenfassungszeile anzeigen (keine Dateinamen oder übereinstimmenden Zeilen; überschreibt /V)

 

/V – Zeigt den gesamten übereinstimmenden Text an (FFIND zeigt standardmäßig nur den ersten Treffer in jeder Datei an)

 

/Y – Zeigt nach der Anzeige jeder Übereinstimmung die Aufforderung „Weiter J/N“ an

 

/Z – Markiert den übereinstimmenden Text

 

FSEARCH ermittelt automatisch den Dateityp (ASCII, UTF8 oder UTF16).

 

FSEARCH legt drei interne Variablen fest:

 

_fsearch_errors – Fehler beim Ausführen von FSEARCH (z. B. Datei/Pfad nicht gefunden, Datei gesperrt, Zugriff verweigert usw.)

 

_fsearch_files – Die Anzahl der Dateien, die eine oder mehrere Übereinstimmungen enthalten

 

_fsearch_matches – Die Gesamtzahl der Übereinstimmungen

 

INTERN

 

Führt den angegebenen internen Befehl aus und ignoriert alle Aliase, Plugins oder externen Apps. Die Syntax lautet:

 

INTERN Befehlsargumente ...

 

If Befehl ist kein interner TCC Befehl gibt INTERNAL einen Fehler zurück.

 

RANDOM

 

Erzeugt eine zufällige Ganzzahl, Bool, Float, Char oder String. Die Syntax lautet:

 

ZUFÄLLIG /I Start Ende - Erstellen Sie eine Ganzzahl >= Anfang und <= Endedem „Vermischten Geschmack“. Seine Anfang und Ende Argumente sind vorzeichenbehaftete 64-Bit-Werte.

 

RANDOM /B – Erstellt einen booleschen Wert (0 oder 1)

 

ZUFÄLLIG /F Anfang, Ende, Präzision - Erstellen Sie eine Gleitkommazahl >= Anfang und <= Ende, mit Präzision Nachkommastellen.

 

ZUFÄLLIG /C Start Ende - Erstellen Sie ein Zeichen zwischen (einschließlich) den Zeichen Anfang und Ende.

 

ZUFÄLLIG /S Anfang, Ende, Länge Erstellen Sie eine Zeichenfolge, die aus Zeichen dazwischen besteht Anfang und Ende (inklusive).

 

ZUFÄLLIG /D n - Rollen Sie ein n seitige Würfel.

 

TRUE

 

Gibt 1 zurück (und setzt ERRORLEVEL auf 1).

 

 


 

 

Take Command 32.0:

 

Take Command, TCC, CMDebug und TCC-RT  werden mit einer neuen Version von Visual Studio erstellt.

 

 

Take Command:

 

Viele Sicherheits-, Leistungs- und Größenverbesserungen.

 

PowerShell Core wurde zur vordefinierten Apps-Liste für das Dialogfeld „Ausführen“ hinzugefügt Take Command Tabs-Konfigurationsdialog.

 

Unterstützung für 8K-Monitore hinzugefügt.

 

 

TCC:

 

Viele Sicherheits-, Leistungs- und Größenverbesserungen.

 

Unterstützung für 8K-Monitore hinzugefügt.

 

Unterstützung für Python 3.13 hinzugefügt.

 

Strg-Umschalt-Bild-auf oder Strg-Umschalt-Bild-ab – öffnet das neue Dialogfeld „Erweiterter Verlauf“ (siehe XHISTORY unten). (Kann durch Ändern von XHistWinOpen im Dialogfeld OPTION / Tastatur / Verlauf neu definiert werden.) Der erweiterte Verlauf zeigt und speichert mehr Informationen über den Befehl als der ursprüngliche Befehlsverlauf:

 

Zeitstempel – Datum und Uhrzeit der Befehlsausführung

Laufzeit – Die verstrichene Zeit (im Format Sekunden.Millisekunden)

Rückgabe – Der vom Befehl zurückgegebene ganzzahlige Wert

CWD – Das aktuelle Arbeitsverzeichnis, als der Befehl ausgeführt wurde

Befehl – ​​Die ursprüngliche Befehlszeile (vor Alias- und Variablenerweiterung)

 

Wenn Sie im Dialog auf einen Verlaufseintrag doppelklicken oder die Eingabetaste drücken, TCC führt den ausgewählten Befehl erneut aus. Wenn Sie Strg-Enter (oder Strg-Doppelklick) drücken, TCC kopiert den Befehl in die Befehlszeile, wo Sie den Befehl bearbeiten können, bevor Sie ihn ausführen.

 

Wenn Sie Umschalt-Eingabetaste (oder Umschalt-Doppelklick) drücken, TCC führt den Befehl in dem durch das CWD-Feld angegebenen Verzeichnis aus und stellt dann das ursprüngliche Verzeichnis wieder her. Sie können die Tasten Strg und Umschalt kombinieren. Beispielsweise zeigt Strg-Umschalt-Eingabe den Befehl in der Befehlszeile zur weiteren Bearbeitung an, bevor das Verzeichnis geändert, der Befehl ausgeführt und das ursprüngliche Verzeichnis wiederhergestellt wird.

 

Sie können mehrere Einträge auswählen (mit Strg-Klick oder Umschalt-Klick). TCC hängt die Befehle an (getrennt durch a &), bevor Sie das Ergebnis an die Befehlszeile übergeben.

 

Wenn der Fokus auf der Listenansicht liegt, führt die Eingabe einer Nummer zur entsprechenden Zeilennummer (ID in der ersten Spalte) in der erweiterten Verlaufsliste.

 

Wenn Sie mit der rechten Maustaste auf einen Eintrag in der Liste klicken, wird ein Dropdown-Kontextmenü mit den folgenden Optionen angezeigt:

 

Kopieren

Kopieren+Anhängen

Schneiden

Löschen

 

Der erweiterte Verlauf kann über das Dialogfeld OPTION/Befehlszeile/Befehlsverlauf aktiviert/deaktiviert werden.

 

Über das Feld Bearbeiten (obere linke Ecke des Dialogs) können Sie im Verzeichnisverlauf nach passenden Zeilen suchen. Passende Unterstützungen erweitert TCC Platzhalter und reguläre Ausdrücke. (Aufgrund der unterschiedlichen Feldoptionen handelt es sich hierbei nicht um eine inkrementelle Suche. Sie müssen die Eingabetaste drücken, bevor die Suche abgeschlossen und die erweiterte Verlaufsliste aktualisiert wird.) Sie können in jedem der erweiterten Verlaufsfelder suchen. Wenn kein Feld angegeben ist, erfolgt die Suche standardmäßig entsprechend der Befehlszeile.

 

ts=...Übereinstimmungszeitstempel (jjjj-mm-tt hh:mm:ss)

 

rt=...Match-Laufzeit (im Format Sekunden.Millisekunden)

 

ret=nÜbereinstimmungs-Rückgabecode (0–256)

 

cwd=...Aktuelles Arbeitsverzeichnis abgleichen

 

cmd=...Befehlszeile anpassen

 

 

IDE / Batch-Debugger:

 

Viele Sicherheits-, Leistungs- und Größenverbesserungen.

 

Unterstützung für 8K-Monitore hinzugefügt.

 

Die Leistung des Syntaxstils für große Dateien wurde verbessert.

 

Der Editor unterstützt jetzt die automatische Vervollständigung für TCC oder CMD-Befehlsnamen, interne Variablen und Variablenfunktionen. Um das Dropdown-Menü für die automatische Vervollständigung anzuzeigen, geben Sie den Teilnamen ein und drücken Sie dann Strg-Eingabetaste.

 

Es gibt zwei neue Optionen im Menü „Datei“:

 

Als HTML speichern – speichert die aktuelle Datei als HTML-Datei.

 

Als XML speichern – speichert die aktuelle Datei als XML-Datei.

 

Es gibt eine neue Option im Menü „Ansicht“:

 

Max. Spalte markieren – Ruft ein Dialogfeld auf, in dem nach einer Spaltennummer gefragt wird. Zeichnet dann eine vertikale Linie entlang dieser Spalte im Bearbeitungsfenster. Dies kann hilfreich sein, um zu lange Zeilen zu erkennen.

 

 

TCEDIT:

 

Viele Sicherheits-, Leistungs- und Größenverbesserungen.

 

Unterstützung für 8K-Monitore hinzugefügt.

 

Die Leistung des Syntaxstils für große Dateien wurde verbessert.

 

Der Editor unterstützt jetzt die automatische Vervollständigung für TCC oder CMD-Befehlsnamen, interne Variablen und Variablenfunktionen. Um das Dropdown-Menü für die automatische Vervollständigung anzuzeigen, geben Sie den Teilnamen ein und drücken Sie dann Strg-Eingabetaste.

 

Es gibt zwei neue Optionen im Menü „Datei“:

 

Als HTML speichern – speichert die aktuelle Datei als HTML-Datei.

 

Als XML speichern – speichert die aktuelle Datei als XML-Datei.

 

Es gibt eine neue Option im Menü „Ansicht“:

 

Max. Spalte markieren – Ruft ein Dialogfeld auf, in dem nach einer Spaltennummer gefragt wird. Zeichnet dann eine vertikale Linie entlang dieser Spalte im Bearbeitungsfenster. Dies kann hilfreich sein, um zu lange Zeilen zu erkennen.

 

 

Hilfe:

 

Hilfe für Take Command, TCC und CMDebug ist jetzt in Englisch, Französisch, Deutsch und Spanisch verfügbar. Sie können die Hilfedateien herunterladen von:

 

JP-Software-Downloads - Take Command, TCC, CMDebug und TCC-RT

 

Der eWriter-Dateibetrachter wurde auf Version 4.0 aktualisiert und der Skin dafür Take Command Hilfe wurde neu geschrieben.

 

Die Hilfe wurde mit einer neuen Version von Help & Manual (9.4.1) erstellt.

 

 

Neue TCMD.INI-Anweisungen:

 

XHCWD=n – Legen Sie die maximale Länge (in Pixel) für die CWD-Spalte im XHistory-Popup-Dialogfeld fest. Der Standardwert ist 240. Das XHistory-Dialogfeld setzt die CWD-Spalte auf den XHCWD-Wert oder die maximale Verzeichnislänge, je nachdem, welcher Wert kleiner ist.

 

 

Aktualisierte Befehle:

 

VERZEICHNIS

 

/F["..."]         Einträge in der Verzeichnisverlaufsliste löschen. Sie können mehrere /F"..."-Argumente haben und diese können Platzhalter enthalten. Wenn Sie das optionale Argument in Anführungszeichen nicht angeben, löscht /F die gesamte Liste.

 

zur Auswahl

 

Die Seite „Tastatur“ enthält unter „Erweiterter Verlauf“ neue Tasteneinträge:

 

XHistWinOpen (standardmäßig Strg-Umschalt-Bild-auf und Strg-Umschalt-Bild-ab) – öffnet das neue Dialogfeld „Erweiterter Verlauf“ (siehe XHISTORY unten)

 

XHistDelete (Standard Strg-D) – Tastenkombination zum Löschen ausgewählter Einträge im Dialogfeld „Erweiterter Verlauf“.

 

XHistEdit (Standard Strg-E) – Tastenkombination zum Bearbeiten des aktuell ausgewählten Eintrags im Dialogfeld „Erweiterter Verlauf“.

 

XHistSearch (Standard Strg-S) – Tastenkombination zum Bearbeiten der Suchzeichenfolge im Dialogfeld „Erweiterter Verlauf“.

 

 

Neue Befehle:

 

UHR

 

Führen Sie Befehle wiederholt aus, zeigen Sie die Ausgabe an und heben Sie die Unterschiede zur letzten Ausführung hervor. Mit WATCH können Sie sehen, wie sich die Programmausgabe im Laufe der Zeit ändert.

 

Die Syntax lautet:

 

ANSEHEN [/C /D /Hn /In / Mn /Nf /Nh /R"regex" /Tn /V] "Befehl ..."

 

/CLöschen Sie vor jedem Lauf die Anzeige und stellen Sie den Cursor auf die Ausgangsposition

 

/DDeaktivieren Sie die Hervorhebungsfärbung

 

/HnNur den Anfang anzeigen n Linien

 

/InIntervall (in Sekunden) zwischen jedem Lauf

 

/MnMaximale Anzahl der Ausführungen des Befehls

 

/NfDeaktivieren Sie die WATCH-Fußzeile

 

/NhDeaktivieren Sie den WATCH-Header

 

/R"regex"Zeigt nur die Ausgabezeilen an, die dem regulären Ausdruck entsprechen

 

/TnNur das Nachgestellte anzeigen n Linien

 

/VAusführliche Ausgabe (Kopf- und Fußzeile)

 

BefehlBefehl(e) zur Ausführung

 

Befehl kann ein interner Befehl, ein Alias, eine Batchdatei oder eine externe Anwendung sein.

 

watch32

 

Beachten Sie, dass Sie Ihre %-Werte verdoppeln müssen, wenn Sie möchten, dass die Variablen durch die angegebenen Befehle statt durch WATCH erweitert werden.

 

 

XGESCHICHTE

 

Ein erweiterter Befehlsverlauf, der die Befehlszeile, das aktuelle Arbeitsverzeichnis, den Rückkehrcode, die Gesamtlaufzeit (Millisekundenauflösung) und den Datums-/Zeitstempel speichert. Der erweiterte Verlauf ersetzt nicht den vorhandenen Befehlsverlauf. XHISTORY kann entweder den erweiterten Verlauf anzeigen/ändern oder ein Dialogfeld aufrufen, in dem Sie Einträge anzeigen/bearbeiten/auswählen können. (Siehe auch Strg-Umschalt-Bild-auf oben.)

 

Die Syntax lautet:

 

XHISTORY [AUS | ON][/D/ F"..." | /M"..." | /Nf /Nh /Q]

 

AUS – Erweiterten Verlauf deaktivieren

 

EIN – Erweiterten Verlauf aktivieren (erweiterter Verlauf kann auch im OPTION-Dialog auf der Befehlszeilenseite aktiviert/deaktiviert werden)

 

/D – Zeigt das XHistory-Dialogfeld an. Sie können Befehle anzeigen, bearbeiten, löschen oder (erneut) ausführen.

 

/F"..." Übereinstimmende Zeilen im Verzeichnisverlauf löschen. Passende Unterstützungen erweitert TCC Platzhalter und reguläre Ausdrücke. Sie können in jedem Feld suchen:

 

/F"ts=..."Übereinstimmungszeitstempel (jjjj-mm-tt hh:mm:ss)

 

/F"rt=..."Match-Laufzeit (im Format Sekunden.Millisekunden)

 

/F"ret=n"Übereinstimmungs-Rückgabecode (0–256)

 

/F"cwd=..."Aktuelles Arbeitsverzeichnis abgleichen

 

/F"cmd=..."Befehlszeile anpassen

 

/M"..." Passende Zeilen im Verzeichnisverlauf finden. Passende Unterstützungen erweitert TCC Platzhalter und reguläre Ausdrücke. Sie können in jedem Feld suchen:

 

/M"ts=..."Übereinstimmungszeitstempel (jjjj-mm-tt hh:mm:ss)

 

/M"rt=..."Match-Laufzeit (im Format Sekunden.Millisekunden)

 

/M"ret=n"Übereinstimmungs-Rückgabecode (0–256)

 

/M"cwd=..."Aktuelles Arbeitsverzeichnis abgleichen

 

/M"cmd=..."Befehlszeile anpassen

 

/Nh – Kopfzeile nicht anzeigen

 

/Nf – Fußzeile nicht anzeigen

 

/Q – Passende erweiterte Verlaufseinträge für /F und /M werden nicht angezeigt.